Skip to content

Commit

Permalink
media-video/qt-recordmydesktop: python-single-r1, EAPI=6
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Feb 21, 2017
1 parent 230f73a commit 2f1df68
Show file tree
Hide file tree
Showing 3 changed files with 18 additions and 26 deletions.
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/rmdPrefsWidget.py.orig 2008-11-23 16:09:14.000000000 +0100
+++ src/rmdPrefsWidget.py 2010-05-24 16:23:30.255865721 +0200
--- a/src/rmdPrefsWidget.py 2008-11-23 16:09:14.000000000 +0100
+++ b/src/rmdPrefsWidget.py 2010-05-24 16:23:30.255865721 +0200
@@ -302,9 +302,29 @@
def remPort(self,lwi):
self.jack_lsp_listSave.takeItem(self.jack_lsp_listSave.row(lwi))
Expand Down
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
Fixes errors reported by desktop-file-validate.

--- src/qt-recordmydesktop.desktop
+++ src/qt-recordmydesktop.desktop
--- a/src/qt-recordmydesktop.desktop
+++ b/src/qt-recordmydesktop.desktop
@@ -1,12 +1,11 @@
[Desktop Entry]
Version=1.0
Expand Down
Original file line number Diff line number Diff line change
@@ -1,12 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=4
EAPI=6

PYTHON_DEPEND="2:2.6"
RESTRICT_PYTHON_ABIS="3.*"
inherit autotools base eutils python
PYTHON_COMPAT=( python2_7 )
inherit autotools python-single-r1

DESCRIPTION="Qt4 interface for RecordMyDesktop"
HOMEPAGE="http://recordmydesktop.sourceforge.net/"
Expand All @@ -24,10 +23,14 @@ IUSE=""
# much care...
RESTRICT="test"

RDEPEND=">=media-video/recordmydesktop-0.3.8
x11-apps/xwininfo"
DEPEND="${RDEPEND}
>=dev-python/PyQt4-4.1[X]"
RDEPEND="
>=dev-python/PyQt4-4.1[X,${PYTHON_USEDEP}]
>=media-video/recordmydesktop-0.3.8
x11-apps/xwininfo
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DOCS=( AUTHORS ChangeLog NEWS README )

Expand All @@ -37,23 +40,12 @@ PATCHES=(
"${FILESDIR}/${P}-pyqt4.patch"
)

pkg_setup() {
python_set_active_version 2
python_pkg_setup
}

src_prepare() {
base_src_prepare
eautoreconf
default

# these deps are required by PyQt4, not this package
sed -e '/^PKG_CHECK_MODULES/d' -i configure.ac || die "sed failed"
eautoreconf

python_convert_shebangs 2 src/qt-recordMyDesktop.in

sed -e 's/@ALL_LINGUAS@//' -i po/Makefile.in.in \
|| die "respect linguas sed failed"
strip-linguas -i po
echo ${LINGUAS} | tr ' ' '\n' > po/LINGUAS
python_fix_shebang src/qt-recordMyDesktop.in
}

0 comments on commit 2f1df68

Please sign in to comment.