Skip to content

Commit

Permalink
games-board/cockatrice: version bump to 20160506
Browse files Browse the repository at this point in the history
Also add the new dependencies for QT5.

Closes: gentoo#1735

Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
GuillaumeSeren authored and monsieurp committed Jul 12, 2016
1 parent 6cb87b6 commit 2f2b7ec
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-board/cockatrice/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST 2016-05-06-Release.tar.gz 6910937 SHA256 379835006f38b603af01cf46d508fd40e862b451045807b444042914e8736fee SHA512 5f90804270907b3a915e763e6a20c39432f76591a11df7198526fde5635314ffbb27026860053c302be1ef1dfce1efa445c5849c72d1220575314d6c3d67e94f WHIRLPOOL a13c531980da2cf172e933c5bcb179f8dc9368514fe7d2ec12a203f54c04aa5258218c6d2fc1bee30826598e1e8c057c437af6810709c26b0863cd2b665bc159
DIST cockatrice_source_20120702.tar.gz 3790304 SHA256 a418124d3df255f2af70a20ff6b13f85361467abe4ea4216602bd3647cfc490e SHA512 119acd394dfe97de72b0be8d1ea8c6178f9d0150dcb50d1aba074c28c8d0f52f2be5758ac3943c49d11f655f02a70fc5f5a7e207b8a2631f73f7178ff17b5c35 WHIRLPOOL 1e5112519ddd0f4107778c97d4cf415959117d7e5854ad9760d50621a77a53d992678470772358c880e89ba35376cbf6abab4687969810c117d2851eae4ec70a
70 changes: 70 additions & 0 deletions games-board/cockatrice/cockatrice-20160506.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit cmake-utils eutils gnome2-utils games

DESCRIPTION="An open-source multiplatform software for playing card games over a network"
HOMEPAGE="https://github.com/Cockatrice/Cockatrice"

SRC_URI="https://github.com/Cockatrice/${PN}/archive/2016-05-06-Release.tar.gz"

S=${WORKDIR}/"Cockatrice-2016-05-06-Release"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="dedicated server"

DEPEND="
dev-libs/libgcrypt:0
dev-libs/protobuf
dev-qt/qtcore:5
dev-qt/qtconcurrent
dev-qt/linguist-tools
dev-qt/qtprintsupport
!dedicated? (
dev-qt/qtmultimedia:5
dev-qt/qtsvg:5
dev-qt/qtgui:5
)"

src_configure() {
local mycmakeargs=(
$(usex dedicated "-DWITHOUT_CLIENT=1 -DWITH_SERVER=1" "$(usex server "-DWITH_SERVER=1" "")")
-DCMAKE_INSTALL_BINDIR="${GAMES_BINDIR}"
-DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}"
-DDATADIR="${GAMES_DATADIR}/${PN}"
-DICONDIR="/usr/share/icons"
-DDESKTOPDIR="/usr/share/applications"
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
prepgamesdirs
}

pkg_preinst() {
games_pkg_preinst
use dedicated || gnome2_icon_savelist
}

pkg_postinst() {
games_pkg_postinst
elog "zonebg pictures are in ${GAMES_DATADIR}/${PN}/zonebg"
elog "sounds are in ${GAMES_DATADIR}/${PN}/sounds"
elog "you can use those directories in cockatrice settings"
use dedicated || gnome2_icon_cache_update
}

pkg_postrm() {
use dedicated || gnome2_icon_cache_update
}

0 comments on commit 2f2b7ec

Please sign in to comment.