Skip to content

Commit

Permalink
kde-plasma/kwin: Do not write GLPlatformInterface config
Browse files Browse the repository at this point in the history
Changing compositor settings in Wayland shall not break X11 sessions.

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
a17r committed Apr 15, 2017
1 parent 4ae9566 commit 301c2e6
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 1 deletion.
37 changes: 37 additions & 0 deletions kde-plasma/kwin/files/kwin-5.9.4-glconfig.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
commit a936516107579df13362f6d2d6f91f26a447d6dd
Author: Martin Gräßlin <[email protected]>
Date: Mon Apr 3 06:53:05 2017 +0200

[kcmkwin/compositing] Do not write GLPlatformInterface config

Summary:
The gui element to select the platform interface is dropped. Thus we
should not store the config for it. This is rather important as changing
compositor settings on Wayland would result in egl being written into the
config which potentially breaks an X11 session.

BUG: 378114

Reviewers: #kwin, #plasma

Subscribers: plasma-devel, kwin

Tags: #kwin

Differential Revision: https://phabricator.kde.org/D5285

diff --git a/kcmkwin/kwincompositing/compositing.cpp b/kcmkwin/kwincompositing/compositing.cpp
index c1cddb89d..102dfd18c 100644
--- a/kcmkwin/kwincompositing/compositing.cpp
+++ b/kcmkwin/kwincompositing/compositing.cpp
@@ -309,10 +309,6 @@ void Compositing::save()
}
kwinConfig.writeEntry("Backend", backend);
kwinConfig.writeEntry("GLCore", glCore);
- const QModelIndex glIndex = m_openGLPlatformInterfaceModel->index(m_openGLPlatformInterface);
- if (glIndex.isValid()) {
- kwinConfig.writeEntry("GLPlatformInterface", glIndex.data(Qt::UserRole).toString());
- }
if (!compositingRequired()) {
kwinConfig.writeEntry("WindowsBlockCompositing", windowsBlockCompositing());
}
5 changes: 4 additions & 1 deletion kde-plasma/kwin/kwin-5.9.4-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -88,7 +88,10 @@ DEPEND="${COMMON_DEPEND}

RESTRICT+=" test"

PATCHES=( "${FILESDIR}/${PN}-5.8.6-libdrm-2.4.78.patch" )
PATCHES=(
"${FILESDIR}/${PN}-5.8.6-libdrm-2.4.78.patch"
"${FILESDIR}/${P}-glconfig.patch"
)

src_prepare() {
kde5_src_prepare
Expand Down

0 comments on commit 301c2e6

Please sign in to comment.