Skip to content

Commit

Permalink
mail-client/roundcube: 1.4.11 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Feb 8, 2021
1 parent 7535f44 commit 304a04b
Show file tree
Hide file tree
Showing 2 changed files with 97 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/roundcube/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST roundcubemail-1.4.10-complete.tar.gz 7043181 BLAKE2B aa442c9e4fb4d31bc9ddd77d888637d9d7afb8ac6c264ca5d378bd7bfc160f2f31379fae208638b2f79e6127add83f0254d1526e22c2ca24656b31ee75dc695e SHA512 e0a661ae5b928ce2c93129775d32a679ad2512ca4af21e8dd1711d38a62818ff9ee1e1fc922aae68e0a8bca034ca780fc3e3e988731a2ce9b2190b2c1d8e08a6
DIST roundcubemail-1.4.11-complete.tar.gz 7048262 BLAKE2B aaf5e6ce5b07577f687788730bc9181334402bb2ff5e78fb306425913b62b4a8f72505547bdcc8673806b48b9ba8252b8059b59399efc95a51877d5c672a4760 SHA512 2bfe0ff3716f76bf9eb5bf5f7b62c738b233c57e67d6ac767c044d1a3a694ae003642d9cc68a18d6f6ba94135aa7ee1692db920e9127128669faee9ddf78fe80
DIST roundcubemail-1.4.8-complete.tar.gz 7032822 BLAKE2B 61c5329d9abe65baba3274d3cb9a6a435f886a0196c2881153da473eb415ad4c63dfdab49c67c75a2fd92ff55f9e6da7bdfcece7041ce408b2be628da47045d4 SHA512 8b7734cdec95954b7e18a0e44957da6ef74b5b0c3d28a1449e8634faa230844f5e0c28954245641758f8b2d9102aa32f279765ed3dfa20fa7b00dee4e5347362
96 changes: 96 additions & 0 deletions mail-client/roundcube/roundcube-1.4.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,96 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit webapp

MY_PN=${PN}mail
MY_PV=${PV/_/-}
MY_P=${MY_PN}-${MY_PV}

DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
HOMEPAGE="https://roundcube.net"

# roundcube is GPL-licensed, the rest of the licenses here are
# for bundled PEAR components, googiespell and utf8.class.php
LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"

IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
REQUIRED_USE="|| ( mysql postgres sqlite )"

# this function only sets DEPEND so we need to include that in RDEPEND
need_httpd_cgi

RDEPEND="
${DEPEND}
>=dev-lang/php-5.4.0[filter,gd,iconv,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
virtual/httpd-php
change-password? (
dev-lang/php[sockets]
)
enigma? (
app-crypt/gnupg
)
mysql? (
|| (
dev-lang/php[mysql]
dev-lang/php[mysqli]
)
)
spell? ( dev-lang/php[curl,spell] )
"

if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
EGIT_BRANCH="master"
BDEPEND="${BDEPEND}
app-arch/unzip
dev-php/composer
net-misc/curl"
else
SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi

src_unpack() {
if [[ "${PV}" == *9999* ]]; then
git-r3_src_unpack
pushd "${S}" > /dev/null || die
mv composer.json-dist composer.json || die
composer install --no-dev || die
./bin/install-jsdeps.sh || die
popd > /dev/null || die
else
default
fi
}

src_install() {
webapp_src_preinst

dodoc CHANGELOG INSTALL README.md UPGRADING

insinto "${MY_HTDOCSDIR}"
doins -r [[:lower:]]* SQL
doins .htaccess

webapp_serverowned "${MY_HTDOCSDIR}"/logs
webapp_serverowned "${MY_HTDOCSDIR}"/temp

webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"

webapp_src_install
}

pkg_postinst() {
webapp_pkg_postinst

if [[ -n ${REPLACING_VERSIONS} ]]; then
elog "You can review the post-upgrade instructions at:"
elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
fi
}

0 comments on commit 304a04b

Please sign in to comment.