Skip to content

Commit

Permalink
dev-python/paramiko: Bump to 2.9.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 24, 2021
1 parent 3c016b2 commit 30d5721
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/paramiko/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST paramiko-2.8.0.tar.gz 332217 BLAKE2B fcd691159b0306204064806881f8a42e7310fe23daf22c5de5ce8124d1496d48606247ab03c7657ff01560f801121a35011e0e615c5e142c41d191568f5b2300 SHA512 15f6e1cab9afdf3285804ce09b3af6c20ffc1f8e50d2549272f0ea545d1fdc858e72c7cba085db85c69aad2033655ae2f025e8ed2bd0dff574bcc03156bdb6ed
DIST paramiko-2.9.0.tar.gz 344160 BLAKE2B b3436934143971b8a16f6100b6d1633b8ce37303d9be16fd228d7c8c83849e3ef8875cb5d3a3cfa8f08e9e72822ed1dfd310782f1fea0b32051758030b7a1f70 SHA512 3385f837ad36131f4508021b4ee0f073f293c0c1005768071becdfa0b9897dc7dd05467009329160f1eee709d32da72fe9e45fb6d61ea099f64748b00cffce14
DIST paramiko-2.9.1.tar.gz 344470 BLAKE2B b750cf27d3a1324193f4c9bb39cbf773a4ad859dd3af3065da82d35177b2be9561c5175e15e9dcf4612a109849b5cfeea0d6a5f08098d3a6f3e529310ea8abc8 SHA512 d86824451be417322e0cdd073b31c103e737663af89f31abb1de21b5fbb9bdaa4b2e49505d2bc599114173df2457dcea308eb5c445fc5191248eb13e4c1eb500
55 changes: 55 additions & 0 deletions dev-python/paramiko/paramiko-2.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="SSH2 protocol library"
HOMEPAGE="https://www.paramiko.org/ https://github.com/paramiko/paramiko/ https://pypi.org/project/paramiko/"
# pypi tarballs are missing test data
#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
IUSE="examples server"

RDEPEND="
>=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
>=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"

distutils_enable_sphinx sites/docs
distutils_enable_tests pytest

src_prepare() {
local PATCHES=(
"${FILESDIR}/${PN}-2.7.1-tests.patch"
)

if ! use server; then
PATCHES+=( "${FILESDIR}/${PN}-2.4.2-disable-server.patch" )
fi
distutils-r1_src_prepare
}

python_install_all() {
distutils-r1_python_install_all

if use examples; then
docinto examples
dodoc -r demos/*
fi
}

0 comments on commit 30d5721

Please sign in to comment.