Skip to content

Commit

Permalink
app-doc/gnucash-docs: Bump to 3.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Signed-off-by: Aaron W. Swenson <[email protected]>
  • Loading branch information
titanofold committed Jul 3, 2019
1 parent c6fbc2a commit 3155f83
Show file tree
Hide file tree
Showing 2 changed files with 86 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-doc/gnucash-docs/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST gnucash-docs-3.2.tar.gz 92387447 BLAKE2B dac502975f885b777c1e91a7ea57478994
DIST gnucash-docs-3.3.tar.gz 92417386 BLAKE2B 200f9b8d3006589eac5f0d66300d658f69f5c55078371c5b416e34784835350de9bd40fc5d85e59116022874294f74e259a034d6ebcaf315b1ea9942b8350c7b SHA512 5887171cbe95f545eb6e647aee2d04a26ab9102643acd8d3e5754000613a7fb08e4470777f7dfbfd0d1ed7609de7a6241cd82f5c7d62f632b2e3751b005bc01e
DIST gnucash-docs-3.4.tar.gz 92762652 BLAKE2B 1aad3f1e7fe5b6ec11b38dc778e8994544d50f9549450b4632e5fcbd370332f05c7c68f9f6bf0e274b654dee6304924d17089b61318e0e4356bf01133ad47508 SHA512 0a64c8fcc88988a08d5b2f7c472356c580dff17b1a2a37b66a6bed790fba9d7bb437955050656656a0be399b2ce1635902f4548f44b62233c1fcd1d75fbb38ec
DIST gnucash-docs-3.5.tar.gz 97187415 BLAKE2B f35a3a25a120d3807771d74ee1c97713e21617f7ac7b4fdc1f58b9d12f7c0cc899a9af6abca21bd4f91a0978ebf5b93604deaae29f39c8ab86bd83ec93e32642 SHA512 aa832a1929ae91b9fe2a6a4ada0c7dbd8c1a4cf76086ec3ab0b82c7396d45aabbb6971f2db788bbdde71a68c8faca5f4621429819ef6c0d1156bcefdc5d289b5
DIST gnucash-docs-3.6.tar.gz 96986567 BLAKE2B 753ee011cadec37320fafe3c0973bc5772c300dcf641ba34f05d03b9c13ec159c10f8571876adecfd7816956f2dfa9e83ad5879387536c15e7d1b138f7e38a47 SHA512 1fd36c74633ba699116914eaef245d4b84ab85a6e65578c602db8b2e3150f7fb97b549c12068a691e38b90ae0fa5cc22f8026b6d50de1ac967eb52b8296eb135
85 changes: 85 additions & 0 deletions app-doc/gnucash-docs/gnucash-docs-3.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,85 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PLOCALES="C de it ja pt ru"
PLOCALE_BACKUP="C"

inherit autotools gnome2 l10n

DESCRIPTION="Documentation package for GnuCash"
HOMEPAGE="http://www.gnucash.org/"
SRC_URI="https://github.com/Gnucash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

SLOT="0"
LICENSE="GPL-2 FDL-1.1"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"

for my_locale in ${PLOCALES}; do
IUSE+=" l10n_${my_locale}"
done

DEPEND="
app-text/docbook-xml-dtd
app-text/docbook-xsl-stylesheets
app-text/rarian
dev-libs/libxml2
dev-libs/libxslt
"

my_l10n_get_locales() {
local l locales
for l in ${PLOCALES[@]}; do
use "l10n_${l}" && locales+=( $l )
done
if [[ ${#locales[@]} -gt 0 ]]; then
echo ${locales[@]}
else
echo $PLOCALE_BACKUP
fi
}

src_prepare() {
default
eautoreconf
}

src_compile() {
:
}

src_install() {
local doc_type my_lang

for doc_type in help guide; do
for my_lang in $(my_l10n_get_locales); do
case $my_lang in
# Both help and guides translated
C|de|it|pt) ;;
ru|ja) # Only guides translated
if [[ ${doc_type} = "help" ]] ; then
elog "Help documentation hasn't been translated for $my_lang"
elog "Will do English instead."
my_lang=C
fi
;;
*)
die "Invalid locale: $my_lang"
;;
esac

cd "${S}/${doc_type}/${my_lang}" || die
emake DESTDIR="${D}" install
done
done

cd "${S}" || die
einstalldocs
}

pkg_postinst() {
gnome2_pkg_postinst
optfeature "You need dev-java/fop to generate pdf files." dev-java/fop
optfeature "You need gnome-extra/yelp to view the docs." gnome-extra/yelp
}

0 comments on commit 3155f83

Please sign in to comment.