Skip to content

Commit

Permalink
games-arcade/xbill: add missing dependency; EAPI=7
Browse files Browse the repository at this point in the history
- Add media-fonts/font-misc-misc and acct-group/gamestat to RDEPEND.
- mv configure.in configure.ac (see bug 426262).
- QA issues (permissions of /var/lib/xbill/scores).

Reported-by: Haelwenn Monnier <[email protected]>
Closes: https://bugs.gentoo.org/692318
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Stefan Strogin <[email protected]>
  • Loading branch information
steils committed Aug 29, 2019
1 parent 023655c commit 32c743a
Show file tree
Hide file tree
Showing 2 changed files with 21 additions and 13 deletions.
4 changes: 2 additions & 2 deletions games-arcade/xbill/files/xbill-2.1-gtk2.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- configure.in.old 2007-12-05 22:37:57.000000000 +0100
+++ configure.in 2007-12-05 22:54:57.000000000 +0100
--- a/configure.in 2007-12-05 22:37:57.000000000 +0100
+++ b/configure.in 2007-12-05 22:54:57.000000000 +0100
@@ -88,12 +88,11 @@
[ --enable-gtk build with the GTK widget set])

Expand Down
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit eutils autotools games
EAPI=7

inherit autotools desktop

DESCRIPTION="A game about an evil hacker called Bill!"
HOMEPAGE="http://www.xbill.org/"
Expand All @@ -13,20 +14,26 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
IUSE="gtk"

RDEPEND="gtk? ( x11-libs/gtk+:2 )
RDEPEND="acct-group/gamestat
media-fonts/font-misc-misc
gtk? ( x11-libs/gtk+:2 )
!gtk? ( x11-libs/libXaw )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

PATCHES=(
"${FILESDIR}"/${P}-gtk2.patch
"${FILESDIR}"/${P}-gentoo.patch
)

src_prepare() {
epatch \
"${FILESDIR}"/${P}-gtk2.patch \
"${FILESDIR}"/${P}-gentoo.patch
default
mv configure.in configure.ac || die
eautoreconf
}

src_configure() {
egamesconf \
econf \
--disable-motif \
$(use_enable gtk) \
$(use_enable !gtk athena)
Expand All @@ -36,5 +43,6 @@ src_install() {
default
newicon pixmaps/icon.xpm ${PN}.xpm
make_desktop_entry ${PN} XBill ${PN}
prepgamesdirs
fowners :gamestat /var/lib/xbill/scores
fperms 664 /var/lib/xbill/scores
}

0 comments on commit 32c743a

Please sign in to comment.