forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.3.0_rc1
- Loading branch information
Showing
2 changed files
with
82 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST geary-0.10.0.tar.xz 917376 SHA256 46197a5a1b8b040adcee99082dbfd9fff9ca804e3bf0055a2e90b13214bdbca5 SHA512 9126acb3608f7aac9236f7d38f5ca549fe04427e244bbff093d06095e09d0ae642ed8e5722325f152a40d3c642a5f31035fca1685749fbe311c4bf3965ee3256 WHIRLPOOL 5d79011682cb47299a147f44380341c05b997b1c825f86df53772be8fcf3818eca85eb55aa325e8c6a6737024166d58044ab01298476a5dad5036092d5a17f74 | ||
DIST geary-0.11.0.tar.xz 945188 SHA256 c947bb1e70bd3d3f4799e59ddd05b27b08a8132674f64c68c919974595bdcd9f SHA512 2baaea15941d7baa31ed545cd0763576a1b2b46ab0ccbe10316f7ca2a0b77523a6c76949de27c1910a3f1c7d13e34f5c6baf29427b0c3e668df8ba7d5ef10f3c WHIRLPOOL 29716c835c0701aefe77f2b114f39631fa6d65e885cb9c71ce069c166030eb8a5bdab98e4f2f86a30c372c26a5be014a732ba9a182a7f5f59c96e6cf971204df |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,81 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
# Keep cmake-utils at the end | ||
inherit eutils gnome2 vala cmake-utils | ||
|
||
DESCRIPTION="A lightweight, easy-to-use, feature-rich email client" | ||
HOMEPAGE="https://wiki.gnome.org/Apps/Geary" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="nls" | ||
|
||
DEPEND=" | ||
>=app-crypt/gcr-3.10.1[gtk,introspection,vala] | ||
app-crypt/libsecret | ||
dev-db/sqlite:3 | ||
dev-libs/glib:2[dbus] | ||
>=dev-libs/libgee-0.8.5:0.8 | ||
dev-libs/libxml2:2 | ||
dev-libs/gmime:2.6 | ||
media-libs/libcanberra | ||
>=net-libs/webkit-gtk-1.10.0:3[introspection] | ||
>=x11-libs/gtk+-3.10.0:3[introspection] | ||
x11-libs/libnotify | ||
" | ||
RDEPEND="${DEPEND} | ||
gnome-base/gsettings-desktop-schemas | ||
nls? ( virtual/libintl ) | ||
" | ||
DEPEND="${DEPEND} | ||
app-text/gnome-doc-utils | ||
dev-util/desktop-file-utils | ||
nls? ( sys-devel/gettext ) | ||
$(vala_depend) | ||
virtual/pkgconfig | ||
" | ||
|
||
src_prepare() { | ||
# https://bugzilla.gnome.org/show_bug.cgi?id=751556 | ||
epatch "${FILESDIR}"/${PN}-0.7.2-cflags.patch | ||
|
||
# https://bugzilla.gnome.org/show_bug.cgi?id=751557 | ||
epatch "${FILESDIR}"/${PN}-0.5.3-vapigen.patch | ||
|
||
# https://bugzilla.gnome.org/show_bug.cgi?id=751558 | ||
epatch "${FILESDIR}"/${PN}-0.6.0-desktopfile.patch | ||
|
||
local i | ||
if use nls ; then | ||
if [[ -n "${LINGUAS+x}" ]] ; then | ||
for i in $(cd po ; echo *.po) ; do | ||
if ! has ${i%.po} ${LINGUAS} ; then | ||
sed -i -e "/^${i%.po}$/d" po/LINGUAS || die | ||
fi | ||
done | ||
fi | ||
else | ||
sed -i -e 's#add_subdirectory(po)##' CMakeLists.txt || die | ||
fi | ||
|
||
cmake-utils_src_prepare | ||
gnome2_src_prepare | ||
vala_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DDESKTOP_UPDATE=OFF | ||
-DGSETTINGS_COMPILE=OFF | ||
-DICON_UPDATE=OFF | ||
-DVALA_EXECUTABLE="${VALAC}" | ||
-DWITH_UNITY=OFF | ||
-DDESKTOP_VALIDATE=OFF | ||
) | ||
|
||
cmake-utils_src_configure | ||
} |