Skip to content

Commit

Permalink
dev-ruby/coffee-rails: add ruby23 revision
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
graaff committed Jul 18, 2016
1 parent 4e27c06 commit 33381a8
Showing 1 changed file with 33 additions and 0 deletions.
33 changes: 33 additions & 0 deletions dev-ruby/coffee-rails/coffee-rails-4.2.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

inherit ruby-fakegem versionator

DESCRIPTION="Coffee Script adapter for the Rails asset pipeline"
HOMEPAGE="https://github.com/rails/coffee-rails"
SRC_URI="https://github.com/rails/coffee-rails/archive/v${PV}.tar.gz -> ${PV}.tar.gz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~amd64-linux"

IUSE=""

ruby_add_rdepend ">=dev-ruby/coffee-script-2.2.0
>dev-ruby/railties-4:* <dev-ruby/railties-5.2:*"

all_ruby_prepare() {
# Avoid dependency on git and bundler.
sed -i -e 's/git ls-files/echo/' \
-e '/bundler/I s:^:#:' Rakefile || die

# Make sure a consistent rails version is loaded.
sed -i -e '4igem "rails"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
}

0 comments on commit 33381a8

Please sign in to comment.