Skip to content

Commit

Permalink
dev-db/pgrouting: Bump to 3.1.1
Browse files Browse the repository at this point in the history
Now supports side-by-side installations for PostgreSQL slots.

Dropped support for building documentation because upstream has a novel
approach.

Signed-off-by: Aaron W. Swenson <[email protected]>
  • Loading branch information
titanofold committed Nov 26, 2020
1 parent 754719b commit 33c0303
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/pgrouting/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pgrouting-2.6.2.tar.gz 6065517 BLAKE2B e27e28cf988040de1e894a857e3d210bc7676271f69d898afc2d6116d5b88d87404723b2cb1283ef77b4449b4aa62a03e2dbcd489ac641a4721a596d29f8fecd SHA512 6e37f66e631d0cc87e135be7d095822aae21656bb56b3d18afa5bececaad8cee6324d37e8e152bbf69e3374ded1f10aa4b9a4c52b873e3a4c43e73cd877fddcb
DIST pgrouting-3.1.1.tar.gz 6133979 BLAKE2B b7657eeb88773773e6166190cda73d9e657774ff81ce7e9f005333a8dcb9d56587d4a793410356092bb1623ec287549dbc60d814b1d5156ff28301503acee776 SHA512 73285d2d47be844203df136b8a8c13d1672ad8c2dac44a1ff7ce16e4676043692a8f2a60a305542132891da83560c49c5eaeb7712e3e3dd250cd8fd550260d4a
56 changes: 56 additions & 0 deletions dev-db/pgrouting/pgrouting-3.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

CMAKE_BUILD_TYPE="Release"
#CMAKE_MAKEFILE_GENERATOR=emake

POSTGRES_COMPAT=( 9.{5..6} {10..13} )
POSTGRES_USEDEP="server"

inherit cmake postgres-multi

DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
HOMEPAGE="http://pgrouting.org/"
LICENSE="GPL-2 MIT Boost-1.0"

SLOT="0"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
IUSE=""

RDEPEND="${POSTGRES_DEP}
>=dev-db/postgis-2.0
dev-libs/boost
sci-mathematics/cgal
"
DEPEND="${RDEPEND}"

# Needs a running psql instance, doesn't work out of the box
RESTRICT="test"

src_prepare() {
cmake_src_prepare
postgres-multi_src_prepare
}

my_src_configure() {
local mycmakeargs=(
-DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)"
)

cmake_src_configure
}

src_configure() {
postgres-multi_foreach my_src_configure
}

src_compile() {
postgres-multi_foreach cmake_build
}

src_install() {
postgres-multi_foreach cmake_src_install
}

0 comments on commit 33c0303

Please sign in to comment.