Skip to content

Commit

Permalink
dev-perl/Authen-PAM: -r bump for EAPI7 + CFLAGS love
Browse files Browse the repository at this point in the history
- EAPI7
- Ensure CFLAGS passed to make/compile (existing logic did nothing)
- Simplify + Indent wiki link for readability

Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Jul 2, 2020
1 parent 7d5bcb8 commit 356eebb
Showing 1 changed file with 51 additions and 0 deletions.
51 changes: 51 additions & 0 deletions dev-perl/Authen-PAM/Authen-PAM-0.160.0-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=NIKIP
DIST_VERSION=0.16
DIST_EXAMPLES=("test.pl")
inherit perl-module

DESCRIPTION="Interface to PAM library"

SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="examples"

RDEPEND="sys-libs/pam"
DEPEND="${RDEPEND}"
BDEPEND="${RDEPEND}"

PATCHES=("${FILESDIR}/no-dot-inc.patch")

src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}

src_test() {
local MODULES=(
"Authen::PAM ${DIST_VERSION}"
)
local failed=()
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"
perl -Mblib="${S}" -M"${dep} ()" -e1
eend $? || failed+=( "$dep" )
done
if [[ ${failed[@]} ]]; then
echo
eerror "One or more modules failed compile:";
for dep in "${failed[@]}"; do
eerror " ${dep}"
done
die "Failing due to module compilation errors";
fi
ewarn "To comprehensively test this module, interactive testing is necessary"
ewarn "For details, see:"
ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
}

0 comments on commit 356eebb

Please sign in to comment.