Skip to content

Commit

Permalink
dev-ml/ocamlnet: Replace STRIP_MASK with RESTRICT=strip
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/651440
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jul 5, 2019
1 parent eaf6a0c commit 361d6a2
Show file tree
Hide file tree
Showing 3 changed files with 6 additions and 21 deletions.
9 changes: 2 additions & 7 deletions dev-ml/ocamlnet/ocamlnet-4.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
Expand All @@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
SLOT="0/${PV}"
KEYWORDS="amd64 ppc x86 x86-fbsd"
IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
RESTRICT="installsources"
RESTRICT="installsources strip"

# the auth-dh compile flag has been disabled as well, since it depends on
# ocaml-cryptgps, which is not available.
Expand Down Expand Up @@ -74,8 +74,3 @@ src_compile() {
emake -j1 opt
fi
}

src_install() {
export STRIP_MASK="*/bin/*"
findlib_src_install
}
9 changes: 2 additions & 7 deletions dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
Expand All @@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
RESTRICT="installsources"
RESTRICT="installsources strip"

# the auth-dh compile flag has been disabled as well, since it depends on
# ocaml-cryptgps, which is not available.
Expand Down Expand Up @@ -70,8 +70,3 @@ src_compile() {
emake -j1 opt
fi
}

src_install() {
export STRIP_MASK="*/bin/*"
findlib_src_install
}
9 changes: 2 additions & 7 deletions dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
Expand All @@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
RESTRICT="installsources"
RESTRICT="installsources strip"

# the auth-dh compile flag has been disabled as well, since it depends on
# ocaml-cryptgps, which is not available.
Expand Down Expand Up @@ -70,8 +70,3 @@ src_compile() {
emake -j1 opt
fi
}

src_install() {
export STRIP_MASK="*/bin/*"
findlib_src_install
}

0 comments on commit 361d6a2

Please sign in to comment.