Skip to content

Commit

Permalink
net-misc/sslh: 1.21 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Jul 12, 2020
1 parent f190115 commit 370e0d7
Show file tree
Hide file tree
Showing 3 changed files with 78 additions and 3 deletions.
1 change: 1 addition & 0 deletions net-misc/sslh/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST sslh-v1.20.tar.gz 60459 BLAKE2B fafb1876df54edce99473db9305eaad77e2b726904724c9c74b3eb2fe8666c219c48b49888b05cc52f993104b69a263ba3c8a271efd1217ba6f73258caa83249 SHA512 eccaddd5a4299206f195c2f7a78840b2f76f8a0cf10a715b5c72f959ed5d3259fc5ea3db8d398b33f0d556d71268b15c870999d742f83383a9d49120e476770a
DIST v1.21.tar.gz 111298 BLAKE2B 46003021292436023c7f2e0d9cbfb283f4ca7497f5da1562cb893a6f20df4ccaa1e6618fa2cdcc28f311518001396d861a5b50e36707327087192b0454f04287 SHA512 e758efc548b68ea4c50a56b6a6169f5c5bcfeb40163ff9968489ef6a3cdf2a69fa46869d1f53e24c6e31de4d44233005608dcf240968de6245653ccb068f692c
75 changes: 75 additions & 0 deletions net-misc/sslh/sslh-1.21.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit flag-o-matic systemd toolchain-funcs

DESCRIPTION="Port multiplexer - accept both HTTPS and SSH connections on the same port"
HOMEPAGE="https://www.rutschle.net/tech/sslh/README.html"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/yrutschle/sslh.git"
inherit git-r3
else
KEYWORDS="~amd64 ~arm ~m68k ~mips ~s390 ~x86"
SRC_URI="https://github.com/yrutschle/sslh/archive/v${PV}.tar.gz"
S=${WORKDIR}/${P}
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="caps pcre systemd tcpd"

RDEPEND="caps? ( sys-libs/libcap )
systemd? ( sys-apps/systemd:= )
tcpd? ( sys-apps/tcp-wrappers )
>=dev-libs/libconfig-1.5"
DEPEND="${RDEPEND}
dev-lang/perl
pcre? ( dev-libs/libpcre:= )"

RESTRICT="test"

src_prepare() {
default
sed -i \
-e '/MAN/s:| gzip -9 - >:>:' \
-e '/MAN=sslh.8.gz/s:.gz::' \
Makefile || die
}

src_compile() {
# On older versions of GCC, the default gnu89 variant
# will reject within-for-loop initializers, bug #595426
# Furthermore, we need to use the gnu variant (gnu99) instead
# of the ISO (c99) variant, as we want the __USE_XOPEN2K macro
# to be defined.
append-cflags -std=gnu99

emake \
CC="$(tc-getCC)" \
USELIBPCRE=$(usev pcre) \
USELIBCAP=$(usev caps) \
USELIBWRAP=$(usev tcpd) \
USESYSTEMD=$(usev systemd)
}

src_install() {
dosbin sslh-{fork,select}
dosym sslh-fork /usr/sbin/sslh

doman ${PN}.8

dodoc ChangeLog README.md

newinitd "${FILESDIR}"/sslh.init.d-3 sslh
newconfd "${FILESDIR}"/sslh.conf.d-2 sslh

if use systemd; then
# Gentoo puts the binaries in /usr/sbin, but upstream puts them in /usr/bin
sed -i -e 's~/usr/bin/~/usr/sbin/~g' scripts/systemd.sslh.service || die
systemd_newunit scripts/systemd.sslh.service sslh.service
exeinto /usr/lib/systemd/system-generators/
doexe systemd-sslh-generator
fi
}
5 changes: 2 additions & 3 deletions net-misc/sslh/sslh-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -12,9 +12,8 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
KEYWORDS="~amd64 ~arm ~m68k ~mips ~s390 ~x86"
MY_P="${PN}-v${PV}"
SRC_URI="https://www.rutschle.net/tech/${PN}/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}
SRC_URI="https://github.com/yrutschle/sslh/archive/v${PV}.tar.gz"
S=${WORKDIR}/${P}
fi

LICENSE="GPL-2"
Expand Down

0 comments on commit 370e0d7

Please sign in to comment.