Skip to content

Commit

Permalink
dev-python/oslo-middleware: 3.34.0 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
prometheanfire committed Feb 17, 2018
1 parent 9ede9e2 commit 399e645
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/oslo-middleware/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST oslo.middleware-3.30.1.tar.gz 56811 BLAKE2B e32cfb91a813883b8f50aa72484f679758efe1f1a0faf9fb3df25c77bc3e0c53464bc77fad95482ec002ca013e17d6f20e4318cd46373decb6ce7ce28f933884 SHA512 ec70d1a5e932c8da7bc4febce8be6b63ec8fb581e2b30051ab655a2a98689467d8e824d073cd19c8dd320d02a975ce22845ca5ea73f1c4e3b5ac9f725452a9db
DIST oslo.middleware-3.34.0.tar.gz 55582 BLAKE2B 0e1af09d016cd5b81c5e0e719d40665ce24e0caaf28a4aae0043f99eee4e74a36669fdaa39330d0ffa13b588892480ee5081e1ffa41b431687c85964c7f30460 SHA512 ba8b418eb11f25ca929db32eb0451fdba757197e1bdba90dd56665e08daaa6f0a4dc6cc07788db4f14ebf2625312d3db69b73acc5cb425fa9e35299f22b6d451
63 changes: 63 additions & 0 deletions dev-python/oslo-middleware/oslo-middleware-3.34.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 )

inherit distutils-r1

DESCRIPTION="Components injected into wsgi pipelines to intercept request/response flows."
HOMEPAGE="https://pypi.python.org/pypi/oslo.middleware"
SRC_URI="mirror://pypi/${PN:0:1}/oslo.middleware/oslo.middleware-${PV}.tar.gz"
S="${WORKDIR}/oslo.middleware-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="test"

CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
test? (
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
>=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
>=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
!~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
>=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
)"
RDEPEND="
${CDEPEND}
>=dev-python/jinja-2.8[${PYTHON_USEDEP}]
!~dev-python/jinja-2.9.0[${PYTHON_USEDEP}]
!~dev-python/jinja-2.9.1[${PYTHON_USEDEP}]
!~dev-python/jinja-2.9.2[${PYTHON_USEDEP}]
!~dev-python/jinja-2.9.3[${PYTHON_USEDEP}]
!~dev-python/jinja-2.9.4[${PYTHON_USEDEP}]
>=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
>=dev-python/statsd-3.2.1[${PYTHON_USEDEP}]
"

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

python_test() {
nosetests tests/ || die "test failed under ${EPYTHON}"
}

0 comments on commit 399e645

Please sign in to comment.