Skip to content

Commit

Permalink
dev-util/buildbot-pkg: Version bump to 1.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
dol-sen committed Jul 26, 2018
1 parent 40e19a4 commit 39f0abe
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/buildbot-pkg/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST buildbot-pkg-0.9.12.tar.gz 4446 BLAKE2B e8077d3b212c968694d2d9e5018c9c985acbff592dbccfeb59543a507f263133268dde57efcacfabb90ea61c3184d34dced21f8e269f619d505166e68c76d43e SHA512 5b9847747924b7e04ae7584f549fa498715e293c6dbdbfef1fe5896c8c96cd65471a908b48c46a32eddbcf8f7b3642402974b4ed3319cf42e90028e772b5e34b
DIST buildbot-pkg-1.1.2.tar.gz 4838 BLAKE2B 437fd8c7d293622b8499c45072d03912cb196afa97f06220cd3279ad01d2426e399e9c95ee063146dd8713f0284981c8a42b79f44028aebd19cbd5a4fe518eff SHA512 11fcf96907274b699da23c667d7a634b1af3752b9edf651e3fd50f030bdd80d3170013ac2c789fc2943d2ca8a84cb02b5caaeb60e646a54cf8b89a5e701e21b5
DIST buildbot-pkg-1.3.0.tar.gz 4835 BLAKE2B d035060ebf1e5823979adea8b7d31a13cc7bf3382eab571090d68db23b476e2fb959deaf249e6d4f2f3b44cf453c407dd0fd39e54a4e5a3d41462b125c573505 SHA512 b8e53de24cd41e31417a4259396fa080c7dad48b5ad2b15d5c9de9eb3fb35196a84f48ba589e8a077382e8a14d760f6148056bbe30972f0542512404e8efbefb
49 changes: 49 additions & 0 deletions dev-util/buildbot-pkg/buildbot-pkg-1.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"

[[ ${PV} == *9999 ]] && inherit git-r3
inherit distutils-r1

MY_PV="${PV/_p/.post}"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="BuildBot common www build tools for packaging releases"
HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-pkg/"
[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"

if [[ ${PV} == *9999 ]]; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi

# No real integration tests for this pkg.
# all tests are related to making releases and final checks for distribution

RDEPEND="
~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
"

DEPEND="${RDEPEND}
>=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
"

S=${WORKDIR}/${MY_P}

PATCHES=(
"${FILESDIR}/${PN}-0.9.15_p1-Removedevelopmentvirtualenvironmenthack.patch"
)

python_install_all() {
distutils-r1_python_install_all
}

0 comments on commit 39f0abe

Please sign in to comment.