Skip to content

Commit

Permalink
Adds patch to check for the existence of repos.conf file, bug #574188
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
Devan Franchini committed Apr 30, 2016
1 parent f4cb075 commit 3b44fea
Show file tree
Hide file tree
Showing 2 changed files with 32 additions and 0 deletions.
31 changes: 31 additions & 0 deletions app-portage/layman/files/layman-2.3.0-dir_check.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
From: Devan Franchini <[email protected]>
Date: Sat, 30 Apr 2016 18:54:39 -0400
Subject: [PATCH] Adds dir check for repos.conf rebuilding

--- a/layman/updater.py 2015-02-07 22:38:49.000000000 -0500
+++ b/layman/updater.py 2016-04-30 18:54:39.103894343 -0400
@@ -182,6 +182,24 @@

def create_repos_conf(self):
self.output.info(" Creating layman's repos.conf file")
+
+ if os.path.isdir(self.config['repos_conf']):
+ msg = ' create_repos_conf() error: %s is a directory and will\n'\
+ ' not be written to.' % self.config['repos_conf']
+ self.output.error(msg)
+ return None
+
+ conf_dir = os.path.dirname(self.config['repos_conf'])
+
+ if not os.path.isdir(conf_dir):
+ try:
+ os.mkdir(conf_dir)
+ except OSError as e:
+ self.output.error(' create_repos_conf() error creating: %s: '\
+ % conf_dir)
+ self.output.error(' "%s"' % e)
+ return None
+
layman_inst = LaymanAPI(config=self.config)
overlays = {}
for ovl in layman_inst.get_installed():
1 change: 1 addition & 0 deletions app-portage/layman/layman-2.3.0-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -61,6 +61,7 @@ python_prepare_all() {
esetup.py setup_plugins
distutils-r1_python_prepare_all
#rm "${S}"/"${PN}"/tests/dtest.py
epatch "${FILESDIR}"/${P}-dir_check.patch
eprefixify etc/layman.cfg layman/config.py
}

Expand Down

0 comments on commit 3b44fea

Please sign in to comment.