Skip to content

Commit

Permalink
dev-python/sip: stop installing .dist-info
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/796251
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Davide Pesavento <[email protected]>
  • Loading branch information
Pesa committed Jun 19, 2021
1 parent 3635732 commit 3b5cdd5
Show file tree
Hide file tree
Showing 3 changed files with 97 additions and 2 deletions.
93 changes: 93 additions & 0 deletions dev-python/sip/sip-4.19.25-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..10} )
inherit python-r1 toolchain-funcs

DESCRIPTION="Python bindings generator for C/C++ libraries"
HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"

MY_P=${PN}-${PV/_pre/.dev}
if [[ ${PV} == *_pre* ]]; then
SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
else
SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${PN}/${PV}/${MY_P}.tar.gz"
fi
S=${WORKDIR}/${MY_P}

# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h
SLOT="0/12"
LICENSE="|| ( GPL-2 GPL-3 SIP )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DEPEND="${PYTHON_DEPS}"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}"/${PN}-4.18-darwin.patch )

src_prepare() {
# Sub-slot sanity check
local sub_slot=${SLOT#*/}
local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h || die)
if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
eerror
eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
eerror "Please update SLOT variable as follows:"
eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
eerror
die "sub-slot sanity check failed"
fi

default
}

src_configure() {
configuration() {
local incdir=$(python_get_includedir)
local myconf=(
"${EPYTHON}"
"${S}"/configure.py
--sysroot="${ESYSROOT}/usr"
--bindir="${EPREFIX}/usr/bin"
--destdir="$(python_get_sitedir)"
--incdir="${incdir#${SYSROOT}}"
--no-dist-info
AR="$(tc-getAR) cqs"
CC="$(tc-getCC)"
CFLAGS="${CFLAGS}"
CFLAGS_RELEASE=
CXX="$(tc-getCXX)"
CXXFLAGS="${CXXFLAGS}"
CXXFLAGS_RELEASE=
LINK="$(tc-getCXX)"
LINK_SHLIB="$(tc-getCXX)"
LFLAGS="${LDFLAGS}"
LFLAGS_RELEASE=
RANLIB=
STRIP=
)
echo "${myconf[@]}"
"${myconf[@]}" || die
}
python_foreach_impl run_in_build_dir configuration
}

src_compile() {
python_foreach_impl run_in_build_dir default
}

src_install() {
installation() {
emake DESTDIR="${D}" install
python_optimize
}
python_foreach_impl run_in_build_dir installation

einstalldocs
use doc && dodoc -r doc/html
}
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI=7

PYTHON_COMPAT=( python3_{7..10} )
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1

DESCRIPTION="Python bindings generator for C/C++ libraries"
Expand All @@ -21,6 +21,7 @@ LICENSE="|| ( GPL-2 GPL-3 SIP )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND="
!<dev-python/sip-4.19.25-r1[${PYTHON_USEDEP}]
!=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
Expand Down
3 changes: 2 additions & 1 deletion dev-python/sip/sip-6.1.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI=7

PYTHON_COMPAT=( python3_{7..10} )
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1

DESCRIPTION="Python bindings generator for C/C++ libraries"
Expand All @@ -21,6 +21,7 @@ LICENSE="|| ( GPL-2 GPL-3 SIP )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND="
!<dev-python/sip-4.19.25-r1[${PYTHON_USEDEP}]
!=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
Expand Down

0 comments on commit 3b5cdd5

Please sign in to comment.