Skip to content

Commit

Permalink
dev-lang/tuprolog: EAPI bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Keri Harris <[email protected]>
  • Loading branch information
keriharris committed Jul 18, 2020
1 parent d9b1eb9 commit 3b65263
Show file tree
Hide file tree
Showing 2 changed files with 80 additions and 0 deletions.
13 changes: 13 additions & 0 deletions dev-lang/tuprolog/files/tuprolog-3.1.0-test-suite.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
--- tuprolog-3.1.0.orig/test/unit/alice/tuprolog/TuPrologTestSuite.java 2020-07-18 15:41:48.236891336 +0200
+++ tuprolog-3.1.0/test/unit/alice/tuprolog/TuPrologTestSuite.java 2020-07-18 15:42:11.458890364 +0200
@@ -22,10 +22,8 @@
ParserTestCase.class,
SpyEventTestCase.class,
VarTestCase.class,
- TestVarIsEqual.class,
JavaDynamicClassLoaderTestCase.class,
ISOIOLibraryTestCase.class,
- SocketLibTestCase.class,
ThreadLibraryTestCase.class
})
public class TuPrologTestSuite {}
67 changes: 67 additions & 0 deletions dev-lang/tuprolog/tuprolog-3.1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit eutils java-pkg-2 java-ant-2

DESCRIPTION="tuProlog is a light-weight Prolog for Internet applications and infrastructures"
HOMEPAGE="http://tuprolog.unibo.it/"
SRC_URI="https://dev.gentoo.org/~keri/distfiles/tuprolog/${P}.tar.gz"

LICENSE="LGPL-3 BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"
RESTRICT="!test? ( test )"

RDEPEND=">=virtual/jdk-1.8:=
dev-java/javassist:3
dev-java/commons-lang:3.1"

DEPEND="${RDEPEND}
dev-java/ant-core
test? (
dev-java/ant-junit4:0
dev-java/junit:4
dev-java/hamcrest-core:1.3
)"

S="${WORKDIR}"/${P}

EANT_GENTOO_CLASSPATH="javassist:3,commons-lang-3.1"

src_prepare() {
eapply "${FILESDIR}"/${P}-no-ikvm.patch
eapply "${FILESDIR}"/${P}-test-suite.patch
eapply_user

cp "${FILESDIR}"/build-${PV}.xml "${S}"/build.xml || die
}

src_compile() {
eant jar $(use_doc)
}

src_test() {
cd "${S}"/dist
java-pkg_jar-from junit:4
java-pkg_jar-from hamcrest-core:1.3
cd "${S}"
ANT_TASKS="ant-junit4" eant test || die "eant test failed"
}

src_install() {
java-pkg_dojar dist/${PN}.jar
java-pkg_dojar dist/2p.jar

if use doc ; then
java-pkg_dohtml -r docs/* || die
dodoc doc/tuprolog-guide.pdf
fi

if use examples ; then
docinto examples
dodoc doc/examples/*.pl
fi
}

0 comments on commit 3b65263

Please sign in to comment.