Skip to content

Commit

Permalink
dev-python/pytoml: Initial version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.7, Repoman-2.3.3
  • Loading branch information
mrueg committed Aug 15, 2017
1 parent 501e1be commit 3bb8bc7
Show file tree
Hide file tree
Showing 3 changed files with 40 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/pytoml/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
DIST pytoml-0.1.14.tar.gz 7679 SHA256 ced2c5d5c240fa96adf2ccbdfa071d51cc80415dd11a4ea800ff0ec987459d34 SHA512 1a608dfa563ebf979bd72b7fad755d3c02afbda6cff99a0ed9a36ca8eecaaea5f89b7b39ff1f5204dd7302e8957c8304dbc4c221e56589c7654edc0fe93f3178 WHIRLPOOL 08c21677b00368b3de54362840179dc5b37e57072ec57799b60ccf59686eee271492aebdbd0ace93db36fdd316d79309b5b6f42c29ea39e976c32946850e2975
DIST toml-test-fa9501a192b7c46b82059caddaef978e3de883dc.tar.gz 16627 SHA256 a097166292d39e69b8d95f20d67e3609e48b96d88a11e76382e1e5e8e099209d SHA512 fea37ebf547633016a83c8e59e7d01a8df2e2795fdb8954246d10e4763675474e112fc52adfed38d3d8ce25bb5a60ef820f798aec2477b0fb7755f1cd6a66a98 WHIRLPOOL 1e409d25c3a3b3050e4e268579f48cedea9964a148a8931eb02a5577be05cc52066a160ec5ebbd42919efd670b81e6601968df20887e152a724e1fba72db0412
12 changes: 12 additions & 0 deletions dev-python/pytoml/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Python</name>
</maintainer>
<upstream>
<remote-id type="github">avakar/pytoml</remote-id>
<remote-id type="pypi">pytoml</remote-id>
</upstream>
</pkgmetadata>
26 changes: 26 additions & 0 deletions dev-python/pytoml/pytoml-0.1.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1

TOML_TEST_COMMIT="fa9501a192b7c46b82059caddaef978e3de883dc"

DESCRIPTION="A TOML-0.4.0 parser/writer for Python"
HOMEPAGE="https://github.com/avakar/pytoml"
SRC_URI="https://github.com/avakar/pytoml/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? ( https://github.com/avakar/toml-test/archive/${TOML_TEST_COMMIT}.tar.gz -> toml-test-${TOML_TEST_COMMIT}.tar.gz )"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

python_test() {
cp -R ../toml-test-${TOML_TEST_COMMIT}/* test/toml-test/ || die
${EPYTHON} test/test.py || die
}

0 comments on commit 3bb8bc7

Please sign in to comment.