Skip to content

Commit

Permalink
dev-python/BitVector: version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
monsieurp committed Jul 12, 2018
1 parent 9b076f5 commit 3bc7df4
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 0 deletions.
23 changes: 23 additions & 0 deletions dev-python/BitVector/BitVector-3.4.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_5,3_6} )

inherit distutils-r1

DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
HOMEPAGE="https://engineering.purdue.edu/kak/dist/ https://pypi.org/project/BitVector/"
SRC_URI="https://engineering.purdue.edu/kak/dist/${P}.tar.gz"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

python_test() {
"${PYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
}
1 change: 1 addition & 0 deletions dev-python/BitVector/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST BitVector-3.4.4.tar.gz 121822 BLAKE2B 1261a7b86130b15eeb3b9ab3565787e673ecb1ee908666eb7784d1da3052bd69b9878a7eeb50df49bfa0ff76b8f2f9d777517c254a320feca187161cf1820701 SHA512 b2310ef712c97538e29d008688efdc10269030bfdf7656733093dd4580ff4dfa171f6d58683c3a6336e909a020ba5100474e18997c1b2a0873a0da2e622ba9ff
DIST BitVector-3.4.6.tar.gz 125137 BLAKE2B 877d2d855ce9eb9f1126df981c92dd8a7a475b15cbccc371ef4649692ac8b449a009d37ffd9c1fc70cd6147faf7758a18c6d83149a22786278f07eb3106a2de0 SHA512 56994692b7cd62f5790a1629d6a653f66f147e674dbc1a5f256dac4462c3eedf6363551165de940e4823d78462f63a44dce03ccd28073db1d93f2e2af436d0ab
DIST BitVector-3.4.7.tar.gz 125013 BLAKE2B 8bd058c485d630755c0c06d4fee0e23c00a32a341d86f92aa22a48aaedf6ececb10bdae22e60a5bdb83f54c013fde8a914266deb64948ded0b2b95f5a4e4168c SHA512 5f9c9d13de6bec4b982a98564561b250152ba0ebdc119c75ddaf3822451dabe417d023fa529fd0ab8f583f86209369937b803d3ed0809ebeb312886504d96dfe
DIST BitVector-3.4.8.tar.gz 126947 BLAKE2B 5033564af4b69b1191ff8317523067b739839e83ed6d9c2c7e3f0910f67635d9d6e8712fabd722971a4652afb6466ae08c7aebe711711e4503a08284f11eb28c SHA512 22d76c33d407b7ff2b0493ed4949189d7fc9ea8fd7497610014ede5f27756b5f91678a5f2da5db5e04f9e85e98378001d0edb5a8c2e3053083d18e547799f3f1

0 comments on commit 3bc7df4

Please sign in to comment.