Skip to content

Commit

Permalink
kde-frameworks/kdelibs4support: 5.72.0 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jul 11, 2020
1 parent ec7819a commit 3bf0bf7
Show file tree
Hide file tree
Showing 2 changed files with 97 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-frameworks/kdelibs4support/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST kdelibs4support-5.70.0.tar.xz 3511172 BLAKE2B fc3f35cc4c039761fe928945dcc9b424e045c60f6a73eec0baa61b6d82c06c79d133f54d815715b07b5699dc354041cd19dd22866d0f2d9d9788a94f9f79d236 SHA512 c736a114ddc654a8e5628b7a24b0666fe1469f9abd5a20d238794a11daa2c9769e1bd9afaa8804b99665981b5ea418706a24226586a3a58695de3164856d9aba
DIST kdelibs4support-5.71.0.tar.xz 3533128 BLAKE2B a8b06fdf1dba37281987e8bf8550e53959e5765c0acf3ee3fcf869bf88d5592c4e0ebee10a7587ad0b142d106e52fd96c30ee40e48df6aa1701d04b8cef98979 SHA512 f624396e2893262c5777eaf2c521ced647445941bad3fe92779cb8a43aa5afe1de31e259dce78fa54f8d499523e621832c613faa639a5eab741a4cf5a027b7b7
DIST kdelibs4support-5.72.0.tar.xz 3533588 BLAKE2B a59142f593397272d4d49b7852263ed63bbf10dda1657196cda97eb7b0d856ae3940e471e5c6b1933d09a0da161d39b9ab8527d0299d026b530a669189bbf67a SHA512 00011144e62d188b686742b0f22ea8f68ea81dcec7d49b52cf0f9c0b13119f46f30185fda684f2e8e4ce1e8805d3eaf39d7b635915c2255a8a23039cc41b95f6
96 changes: 96 additions & 0 deletions kde-frameworks/kdelibs4support/kdelibs4support-5.72.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,96 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ECM_HANDBOOK="true"
ECM_QTHELP="false"
PVCUT=$(ver_cut 1-2)
QTMIN=5.14.2
VIRTUALX_REQUIRED="test"
inherit ecm kde.org

DESCRIPTION="Framework easing the development transition from KDELibs 4 to KF 5"
LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="libressl X"

BDEPEND="
dev-lang/perl
dev-perl/URI
"
COMMON_DEPEND="
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtnetwork-${QTMIN}:5[ssl]
>=dev-qt/qtprintsupport-${QTMIN}:5
>=dev-qt/qtsvg-${QTMIN}:5
>=dev-qt/qttest-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
=kde-frameworks/kauth-${PVCUT}*:5
=kde-frameworks/kcodecs-${PVCUT}*:5
=kde-frameworks/kcompletion-${PVCUT}*:5
=kde-frameworks/kconfig-${PVCUT}*:5
=kde-frameworks/kconfigwidgets-${PVCUT}*:5
=kde-frameworks/kcoreaddons-${PVCUT}*:5
=kde-frameworks/kcrash-${PVCUT}*:5
=kde-frameworks/kdbusaddons-${PVCUT}*:5
>=kde-frameworks/kded-${PVCUT}:5
=kde-frameworks/kdesignerplugin-${PVCUT}*:5
=kde-frameworks/kdoctools-${PVCUT}*:5
=kde-frameworks/kemoticons-${PVCUT}*:5
=kde-frameworks/kglobalaccel-${PVCUT}*:5
=kde-frameworks/kguiaddons-${PVCUT}*:5
=kde-frameworks/ki18n-${PVCUT}*:5
=kde-frameworks/kiconthemes-${PVCUT}*:5
=kde-frameworks/kio-${PVCUT}*:5
=kde-frameworks/kitemviews-${PVCUT}*:5
=kde-frameworks/kjobwidgets-${PVCUT}*:5
=kde-frameworks/knotifications-${PVCUT}*:5
=kde-frameworks/kparts-${PVCUT}*:5
=kde-frameworks/kservice-${PVCUT}*:5
=kde-frameworks/ktextwidgets-${PVCUT}*:5
=kde-frameworks/kunitconversion-${PVCUT}*:5
=kde-frameworks/kwidgetsaddons-${PVCUT}*:5
=kde-frameworks/kwindowsystem-${PVCUT}*:5
=kde-frameworks/kxmlgui-${PVCUT}*:5
=kde-frameworks/solid-${PVCUT}*:5
app-text/docbook-xml-dtd:4.2
virtual/libintl
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
X? (
>=dev-qt/qtx11extras-${QTMIN}:5
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libxcb
)
"
DEPEND="${COMMON_DEPEND}
>=dev-qt/designer-${QTMIN}:5
test? ( >=dev-qt/qtconcurrent-${QTMIN}:5 )
X? ( x11-base/xorg-proto )
"
RDEPEND="${COMMON_DEPEND}
=kde-frameworks/kinit-${PVCUT}*:5
=kde-frameworks/kitemmodels-${PVCUT}*:5
>=dev-qt/qtxml-${QTMIN}:5
"

RESTRICT+=" test"

src_prepare() {
ecm_src_prepare
if ! use handbook; then
sed -e "/kdoctools_install/ s/^/#DONT/" -i CMakeLists.txt || die
fi
}

src_configure() {
local mycmakeargs=(
$(cmake_use_find_package X X11)
)

ecm_src_configure
}

0 comments on commit 3bf0bf7

Please sign in to comment.