Skip to content

Commit

Permalink
app-crypt/tpm2-pkcs11: Bump to 1.4.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Salah Coronya <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
salahcoronya authored and juippis committed Sep 12, 2020
1 parent 3f39354 commit 3dead77
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/tpm2-pkcs11/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tpm2-pkcs11-1.3.1.tar.gz 1256873 BLAKE2B 16bf9c2806fe515cfc31e5885c940774d8d1a04d8a780c8a119db4d9c684e6db3ad3f719fa09d9dc7b6b0fb09212aa4745c53bd7253fd444ebfcb6b8f1dbeb3a SHA512 031b7411c135b2cb3b8f7c38af69a46e65088c4dc1da13ae5c44f92d2a2e293dfe2bea0adc68eb3e64b02b5445f55c353c5c209ecbc977411747fbd429ebdc86
DIST tpm2-pkcs11-1.3.2.tar.gz 1260000 BLAKE2B 219af608db4c72b9bd6c471af9499a4e78a4c9ba6afff72681830cd2f6ce174bc684b9b33c16d263bd6069f0f17f3c92afc56b03779aea38236f36232cd0e5ce SHA512 cca15ace5e6c576591c3432eabb0de98f276a334785b021aa28601c9a77686737c23702fd0ac384feeaf71c8966eccc0006ba428b400de58f811848538ffa978
DIST tpm2-pkcs11-1.4.0.tar.gz 1334539 BLAKE2B 7f165fab37577903da98c5d3c134fe22e0f630e9494061fe8ced3293b96e2c830650090d8aa349c8ce57fea74c07774415279ef5fbde8db628c8607f2b3203cf SHA512 b271500c7aab256edf4b9e070e700bbc8162db070cd8dfe49289db60d8c4527b8e54c794beb8c97fda0d989e095ac6cb790898912993db1906b7139942c87ffb
3 changes: 3 additions & 0 deletions app-crypt/tpm2-pkcs11/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -9,5 +9,8 @@
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<use>
<flag name="fapi">Enable feature API backend</flag>
</use>
</pkgmetadata>

58 changes: 58 additions & 0 deletions app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_REQ_USE="sqlite"

inherit distutils-r1

DESCRIPTION="A PKCS#11 interface for TPM2 hardware"
HOMEPAGE="https://tpm2-software.github.io/"
SRC_URI="https://github.com/tpm2-software/tpm2-pkcs11/releases/download/${PV}/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"

IUSE="fapi"

# Test requires the IBM TPM simulator that's not in portage
RESTRICT="test"

RDEPEND="app-crypt/p11-kit
app-crypt/tpm2-abrmd
app-crypt/tpm2-tools[fapi?]
!fapi? ( app-crypt/tpm2-tss )
fapi? ( >=app-crypt/tpm2-tss-3.0.0[fapi] )
dev-db/sqlite:3
dev-libs/openssl
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"

DEPEND="${RDEPEND}"
BDEPEND="sys-devel/autoconf-archive
virtual/pkgconfig"

src_configure() {
econf \
$(use_enable fapi)
}

src_compile() {
default
cd "${S}/tools" || die
BUILD_DIR="${S}/tools" python_foreach_impl distutils-r1_python_compile
}

src_install() {
default
cd "${S}/tools" || die
BUILD_DIR="${S}/tools" python_foreach_impl distutils-r1_python_install
dobin "${S}/tools/tpm2_ptool"
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 3dead77

Please sign in to comment.