Skip to content

Commit

Permalink
app-accessibility/sphinx2: Port to EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
SoapGentoo committed Dec 29, 2017
1 parent a93170c commit 3deb978
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 23 deletions.
35 changes: 21 additions & 14 deletions app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch
Original file line number Diff line number Diff line change
@@ -1,20 +1,17 @@
diff --git a/src/Makefile.am b/src/Makefile.am
index 05a4f8a..23d0309 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
-SUBDIRS = libsphinx2 \
- libsphinx2fe \
+SUBDIRS = libsphinx2fe \
libsphinx2ad \
+ libsphinx2 \
examples
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl Welcome to the Sphinx-2 automated build system.
dnl try not to hurt yourself ;)

-AC_INIT(configure.in)
+AC_INIT(configure.ac)
AM_INIT_AUTOMAKE(sphinx2,0.6)

diff --git a/src/libsphinx2/Makefile.am b/src/libsphinx2/Makefile.am
index 66f0ac3..537381c 100644
CFLAGS=${CFLAGS:--g -O2 -Wall}
--- a/src/libsphinx2/Makefile.am
+++ b/src/libsphinx2/Makefile.am
@@ -88,7 +88,7 @@ libsphinx2_la_SOURCES = \
@@ -88,7 +88,7 @@
word_fsg.c


Expand All @@ -23,3 +20,13 @@ index 66f0ac3..537381c 100644

# [email protected] - Added for Solaris build
# LDADD = -L/usr/demo/SOUND/lib/ -laudio
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
-SUBDIRS = libsphinx2 \
- libsphinx2fe \
+SUBDIRS = libsphinx2fe \
libsphinx2ad \
+ libsphinx2 \
examples

29 changes: 20 additions & 9 deletions app-accessibility/sphinx2/sphinx2-0.6.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="2"
EAPI=6

inherit autotools eutils
inherit autotools

MY_P=${P/_/}
S=${WORKDIR}/${MY_P}

DESCRIPTION="CMU Speech Recognition-engine"
HOMEPAGE="http://fife.speech.cs.cmu.edu/sphinx/"
Expand All @@ -15,15 +14,27 @@ SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
IUSE="static-libs"

S=${WORKDIR}/${MY_P}
PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )

src_prepare() {
epatch "${FILESDIR}"/${P}-as-needed.patch
default
mv configure.{in,ac} || die
eautoreconf
}

src_configure() {
econf $(use_enable static-libs static)
}

src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README doc/README.bin doc/README.lib doc/SCHMM_format doc/filler.dict doc/phoneset doc/phoneset-old
dohtml doc/phoneset_s2.html doc/sphinx2.html
HTML_DOCS=( doc/{phoneset_s2,sphinx2}.html )
default
dodoc doc/{README.{bin,lib},SCHMM_format,filler.dict,phoneset{,-old}}

if ! use static-libs; then
find "${D}" -name '*.la' -delete || die
fi
}

0 comments on commit 3deb978

Please sign in to comment.