Skip to content

Commit

Permalink
app-i18n/skkserv: update to EAPI 6
Browse files Browse the repository at this point in the history
Gentoo-Bug: 621952

Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
hattya committed Jun 25, 2017
1 parent 914d77b commit 3e28127
Show file tree
Hide file tree
Showing 3 changed files with 26 additions and 26 deletions.
22 changes: 13 additions & 9 deletions app-i18n/skkserv/files/skkserv.initd
Original file line number Diff line number Diff line change
@@ -1,15 +1,19 @@
#!/sbin/openrc-run
# Copyright 1999-2004 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

start() {
ebegin "Starting skkserv"
start-stop-daemon --start --quiet --exec /usr/sbin/skkserv
eend $?
extra_started_commands="reload"

description_reload="Reload the SKK-JISYO.L"

command="/usr/sbin/${SVCNAME}"

depend() {
need net
}

stop() {
ebegin "Stopping skkserv"
start-stop-daemon --stop --quiet --exec /usr/sbin/skkserv
eend $?
reload() {
ebegin "Reloading ${SVCNAME}"
start-stop-daemon --signal INT --name "${command}"
eend ${?}
}
8 changes: 4 additions & 4 deletions app-i18n/skkserv/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Cjk</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Cjk</name>
</maintainer>
</pkgmetadata>
22 changes: 9 additions & 13 deletions app-i18n/skkserv/skkserv-9.6-r3.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=3
inherit eutils
EAPI="6"

MY_P="skk${PV}mu"

Expand All @@ -15,27 +14,24 @@ SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""

DEPEND=">=app-i18n/skk-jisyo-200210"

DEPEND="app-i18n/skk-jisyo"
S="${WORKDIR}/skk-${PV}mu"

src_prepare() {
epatch "${FILESDIR}"/${PN}-segfault.patch
epatch "${FILESDIR}"/${PN}-headers.patch
}
PATCHES=(
"${FILESDIR}"/${PN}-segfault.patch
"${FILESDIR}"/${PN}-headers.patch
)

src_configure() {
econf --libexecdir="${EPREFIX}"/usr/sbin
}

src_compile() {
cd skkserv
emake || die
emake -C ${PN}
}

src_install() {
cd skkserv
dosbin skkserv || die
dosbin ${PN}/${PN}

newinitd "${FILESDIR}"/skkserv.initd skkserv
newinitd "${FILESDIR}"/${PN}.initd ${PN}
}

0 comments on commit 3e28127

Please sign in to comment.