Skip to content

Commit

Permalink
dev-util/bcc: version bump to 0.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
zmedico committed Mar 19, 2017
1 parent 08a3050 commit 3e74f19
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/bcc/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST bcc-0.1.8.tar.gz 694032 SHA256 7535d0dec063454a858337dd07211ad2a207f8fa5665a3fad166f38415e50d70 SHA512 d5a0ba306043f8601c7e358546a57e518f2843228dbeca71d483385b00505af46c89eb92437955e9c325d9b326314101b344e8ca4930bca4161614ca1c893301 WHIRLPOOL 198bdcd72b1a701f8a73fa3ede9385dff2cc0869859962841187692838e002cb78a753f128084d67450d5aeb01034b873268188cecf4af188a5db7a67e676b50
DIST bcc-0.2.0.tar.gz 1195653 SHA256 8bdea41286dda0605e3e52fc76d345356dc637434935a112e6378e2dcb439a70 SHA512 edb696a5382e2f56d06e6b8b65c37b50e719da944fbce43cbad116c773e759fb51837d57ae3d159d83a489dfd0254b9f50b97dab7116465d57f787cf50d58808 WHIRLPOOL ffa4b47dbb16a73699176bd2926763588c6f5ed73052d58ce8f9c51af1eba82c73ac541458b34d6fbd8cd9b698b37bfedc9c9f312967ce639f45daf4789138b2
DIST bcc-0.3.0.tar.gz 1645152 SHA256 88f54dff96c30c6e7b45f475938eef790b1c9485f794b1ac6791c4e56007f7cc SHA512 e5a0f9ad1b0ba865b5644a5a4a0ad130708aac882239ed545bcfd74a5d80328361bc92287bad5569710849682501841e89279089efc71a97da4e02bfc709b916 WHIRLPOOL fb06e4bd7e5ffbee104b5ad4d6e6a9004fc77dccf9f9cdebfa16741c899ce16c0154d6700f9eb6f8754c90da69eeb17ac9a3e878b5f75965dbccd13f6ad35abb
51 changes: 51 additions & 0 deletions dev-util/bcc/bcc-0.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit cmake-utils linux-info python-single-r1 python-utils-r1

DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
HOMEPAGE="https://iovisor.github.io/bcc/"
EGIT_COMMIT="v${PV}"
SRC_URI="https://github.com/iovisor/bcc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
RESTRICT="test"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND=">=dev-libs/elfutils-0.166:=
sys-devel/clang:=
>=sys-devel/llvm-3.7:=[llvm_targets_BPF(+)]
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}-${EGIT_COMMIT#v}

pkg_pretend() {
local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
~BPF_JIT ~BPF_EVENTS"

check_extra_config
}

pkg_setup() {
python-single-r1_pkg_setup
}

src_configure() {
local mycmakeargs=(
-DREVISION=${PV%%_*}
)

cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
python_fix_shebang "${ED}"
}

0 comments on commit 3e74f19

Please sign in to comment.