Skip to content

Commit

Permalink
games-roguelike/scourge: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Sep 14, 2016
1 parent 42e5709 commit 3e8d4de
Show file tree
Hide file tree
Showing 3 changed files with 68 additions and 4 deletions.
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- scourge-0.21.1.src/scourge/configure.in
+++ scourge-0.21.1.src/scourge/configure.in
--- a/configure.in
+++ b/configure.in
@@ -4,7 +4,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(src/scourge.h)
Expand Down
4 changes: 2 additions & 2 deletions games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/squirrel/squtils.h.old 2012-08-30 18:06:43.474037926 +0200
+++ src/squirrel/squtils.h 2012-08-30 18:14:13.300261523 +0200
--- a/src/squirrel/squtils.h 2012-08-30 18:06:43.474037926 +0200
+++ b/src/squirrel/squtils.h 2012-08-30 18:14:13.300261523 +0200
@@ -8,6 +8,9 @@
#define SQ_FREE(__ptr,__size) sq_vm_free(__ptr,__size);
#define SQ_REALLOC(__ptr,__oldsize,__size) sq_vm_realloc(__ptr,__oldsize,__size);
Expand Down
64 changes: 64 additions & 0 deletions games-roguelike/scourge/scourge-0.21.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools eutils wxwidgets

DESCRIPTION="A graphical rogue-like adventure game"
HOMEPAGE="https://sourceforge.net/projects/scourge/"
SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz
mirror://sourceforge/${PN}/${P}.data.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="
media-libs/freetype:2
media-libs/libsdl[joystick,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-net
media-libs/sdl-ttf
virtual/libintl
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
sys-devel/gettext"

S=${WORKDIR}/${PN}

PATCHES=(
"${FILESDIR}"/${P}-gcc47.patch
"${FILESDIR}"/${P}-automake-1.13.patch
)

src_prepare() {
default

# bug #257601
sed -i \
-e '/AC_CHECK_HEADERS.*glext/ s:):, [#include <GL/gl.h>] ):' \
configure.in || die
sed -i \
-e '/snprintf/s/tmp, 256/tmp, sizeof(tmp)/' \
src/scourgehandler.cpp || die
mv configure.{in,ac} || die
eautoreconf
}

src_configure() {
econf \
--with-data-dir=/usr/share/${PN} \
--localedir=/usr/share/locale
}

src_install() {
default
insinto /usr/share/${PN}
doins -r ../scourge_data/*
doicon assets/scourge.png
make_desktop_entry scourge S.C.O.U.R.G.E.
}

0 comments on commit 3e8d4de

Please sign in to comment.