Skip to content

Commit

Permalink
dev-java/oracle-jdk-bin: Version bump to 9.0.4
Browse files Browse the repository at this point in the history
Closes: gentoo#6885
  • Loading branch information
labre authored and chewi committed Jan 19, 2018
1 parent 1dcfa78 commit 3ec59c9
Show file tree
Hide file tree
Showing 2 changed files with 242 additions and 0 deletions.
3 changes: 3 additions & 0 deletions dev-java/oracle-jdk-bin/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -15,3 +15,6 @@ DIST jdk-8u152-solaris-x64.tar.gz 101758540 BLAKE2B 18b04a0eebc618148bdb215d4ca2
DIST jdk-9.0.1_linux-x64_bin.tar.gz 354531775 BLAKE2B c8b81f2286a0c3c4aa8f617f4638fb0dfd70a318acb31ff6a650f566aaa0752a8bc0023ec2e4af99e2a0b6f63f30b21ac1e46d920beec486966f498a37e49cea SHA512 c62ae164553830ef2ab8fbeb6d8674ac0db3e845cabe969f33acf79beb66a16ca5096f4c3d5712d87a55b1a791ac0908b4909e8276661ee24900ad8e0a983a55
DIST jdk-9.0.1_osx-x64_bin.dmg 400669840 BLAKE2B 1fbdbc46c2771a8d7c0d38074e4d145ad3ed32bc1f9ad6bbadecb232e5d96f8bb607839309a7fffcf9fa6731c9f43586033ab96ff1a2761c44a1d19618fc0999 SHA512 f84ea7be92b3cb219fb3b2c642e0ea088cacd252a7a795f9b65483eba7cc15bfa2ff139112d18c3eae1e7618b6aa457aca3aaaec8218581a54c81f263ab02a22
DIST jdk-9.0.1_solaris-sparcv9_bin.tar.gz 216899843 BLAKE2B 54d5f6d903722f805d9d471aec40b8ac5bb74fa316caf81cd7e1b32f20263f2417b7edcfd6415708b9abee04cba5ad350417af3649f6c5a2c7f71fc5dd5f2639 SHA512 76ed079f2adb7b922dbfb56feb2c6aa3e30e745328b5beab4f67966b42dde509cc0e92c80bf7e5e43b1415d24350e49e3f229d15ddac3ecaa8f8a500b2f6bb79
DIST jdk-9.0.4_linux-x64_bin.tar.gz 354635831 BLAKE2B 6d102ca812c7fcf03b611d95880af51916dde52f09f3a5b972abd6575c73e8cca1855fb50ac00aac3f4643a1e422b5fdb97a746608b5a4235d8664926a061730 SHA512 787addfcf3d4736507ad8fa54b22894a33d39bde01d9d187d5c9f3433b43c9e8b14404a8366d0bc8510faa8936274bbfa304109d3927aa323b3f8a285efaffd6
DIST jdk-9.0.4_osx-x64_bin.dmg 400672048 BLAKE2B 0bcc3643ccbc72cd98aca71823e06fd60068a7e1d72c7ce59f8e4c26bb9461a207f57ef239b244ec05c8f843666f2854b07a5f05841819cfe79ed8fefafb3650 SHA512 34191b5802c2d369f890cb1b563f77ee040b9af6ee4fc8ae81974f46afea675401e2a02803fc4345e11bab1103397dd8b583d68bb81edcdd02902cb3e595cc52
DIST jdk-9.0.4_solaris-sparcv9_bin.tar.gz 217025485 BLAKE2B 6b3d4f4701ff3349f8acce727fcfcb06ce420e54dd32d2e6b91b71aa898a8d6a293375ec2cb0c66f14a5df77a6f5b7016160572b995ad84a593e9d5c6c928184 SHA512 9418a725a33dfbedf7f692abfb92550f23fca594fa8c1b85934d601284261339f177a32af7440e0b09233b2e99b2fd7cef835c54252cec6a645ea322a389de14
239 changes: 239 additions & 0 deletions dev-java/oracle-jdk-bin/oracle-jdk-bin-9.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,239 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit desktop gnome2-utils java-vm-2 prefix

KEYWORDS="-* ~amd64 ~x64-macos ~sparc64-solaris"

declare -A ARCH_FILES
ARCH_FILES[amd64]="jdk-${PV}_linux-x64_bin.tar.gz"
ARCH_FILES[sparc64-solaris]="jdk-${PV}_solaris-sparcv9_bin.tar.gz"
ARCH_FILES[x64-macos]="jdk-${PV}_osx-x64_bin.dmg"

for keyword in ${KEYWORDS//-\*} ; do
SRC_URI+=" ${keyword#\~}? ( ${ARCH_FILES[${keyword#\~}]} )"
done

DESCRIPTION="Oracle's Java SE Development Kit"
HOMEPAGE="http://www.oracle.com/technetwork/java/javase/"
LICENSE="Oracle-BCLA-JavaSE"
SLOT="${PV%%.*}"
IUSE="alsa commercial cups doc +fontconfig +gentoo-vm gtk2 gtk3 headless-awt javafx nsplugin selinux source"
REQUIRED_USE="javafx? ( alsa fontconfig ^^ ( gtk2 gtk3 ) )"
RESTRICT="fetch preserve-libs strip"
QA_PREBUILT="*"

# NOTES:
#
# * cups is dlopened.
#
# * libpng is also dlopened but only by libsplashscreen, which isn't
# important, so we can exclude that.
#
# * We still need to work out the exact AWT and JavaFX dependencies
# under MacOS. It doesn't appear to use many, if any, of the
# dependencies below.
#
RDEPEND="!x64-macos? (
!headless-awt? (
x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
x11-libs/libXrender
x11-libs/libXtst
)
javafx? (
dev-libs/atk
dev-libs/glib:2
dev-libs/libxml2:2
dev-libs/libxslt
media-libs/freetype:2
x11-libs/gdk-pixbuf
x11-libs/libX11
x11-libs/libXtst
x11-libs/libXxf86vm
x11-libs/pango
virtual/opengl
gtk2? (
x11-libs/cairo
x11-libs/gtk+:2
)
gtk3? (
x11-libs/cairo[glib]
x11-libs/gtk+:3
)
)
)
alsa? ( media-libs/alsa-lib )
cups? ( net-print/cups )
doc? ( dev-java/java-sdk-docs:${SLOT} )
fontconfig? ( media-libs/fontconfig:1.0 )
!prefix? ( sys-libs/glibc:* )
selinux? ( sec-policy/selinux-java )"

pkg_nofetch() {
einfo "Please download ${ARCH_FILES[${ARCH}]} and move it to"
einfo "${DISTDIR}:"
einfo
einfo " http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html"
einfo
einfo "If the above mentioned URL does not point to the correct version anymore,"
einfo "please download the file from Oracle's Java download archive:"
einfo
einfo " http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase9-3934878.html"
einfo
}

src_unpack() {
if use x64-macos ; then
S="${WORKDIR}/Contents/Home"
mkdir -p "${T}"/dmgmount || die
hdiutil attach "${DISTDIR}/${A}" -mountpoint "${T}"/dmgmount || die
xar -Oxf "${T}"/dmgmount/JDK\ ${PV}.pkg jdk${PV//.}.pkg/Payload | zcat | cpio -idv || die
hdiutil detach "${T}"/dmgmount || die
else
S="${WORKDIR}/jdk-${PV}"
default
fi
}

src_install() {
local dest="/opt/${P}"
local ddest="${ED}${dest#/}"

# Create files used as storage for system preferences.
mkdir .systemPrefs || die
touch .systemPrefs/.system.lock || die
touch .systemPrefs/.systemRootModFile || die

if ! use alsa ; then
rm -vf lib/libjsoundalsa.* || die
fi

if ! use commercial ; then
rm -vfr jmods/*.jfr.* lib/jfr* \
lib/missioncontrol || die
fi

if use headless-awt ; then
rm -vf lib/lib*{[jx]awt,splashscreen}* \
bin/{appletviewer,javaws,policytool} || die
fi

if ! use javafx ; then
rm -vf lib/lib*{decora,fx,glass,prism}* \
lib/libgstreamer-lite.* lib/*fx* \
bin/javapackager jmods/javafx* || die
else
if ! use gtk2 ; then
rm -vf lib/libglassgtk2.* || die
elif ! use gtk3 ; then
rm -vf lib/libglassgtk3.* || die
fi
fi

if ! use nsplugin ; then
rm -vf lib/libnpjp2.* || die
else
local nsplugin=$(echo lib/libnpjp2.*)
local nsplugin_link=${nsplugin##*/}
nsplugin_link=${nsplugin_link/./-${PN}-${SLOT}.}
dosym "${dest}/${nsplugin}" "/usr/$(get_libdir)/nsbrowser/plugins/${nsplugin_link}"
fi

if ! use source ; then
rm -v lib/src.zip || die
fi

# Even though plugins linked against multiple ffmpeg versions are
# provided, they generally lag behind what Gentoo has available.
rm -vf lib/libavplugin* || die

# Prune all fontconfig files so that libfontconfig will be used.
rm -v lib/fontconfig.* || die

# Install desktop file for the Java Control Panel. Using
# ${PN}-${SLOT} to prevent file collision with JRE and other slots.
if [[ -d lib/desktop/icons ]] ; then
local icon
pushd lib/desktop/icons >/dev/null || die
for icon in */*/apps/sun-jcontrol.png ; do
insinto /usr/share/icons/"${icon%/*}"
newins "${icon}" sun-jcontrol-${PN}-${SLOT}.png
done
popd >/dev/null || die
make_desktop_entry \
"${dest}"/bin/jcontrol \
"Java Control Panel for Oracle JDK ${SLOT}" \
sun-jcontrol-${PN}-${SLOT} \
"Settings;Java;"
fi

dodir "${dest}"
cp -pPR bin conf include jmods lib "${ddest}" || die

# Only install Gentoo-specific fontconfig if flag is disabled.
# https://docs.oracle.com/javase/8/docs/technotes/guides/intl/fontconfig.html
if ! use fontconfig ; then
insinto "${dest}"/lib/
doins "$(prefixify_ro "${FILESDIR}"/fontconfig.Gentoo.properties)"
fi

# Needs to be done before CDS, bug #215225.
java-vm_set-pax-markings "${ddest}"

# See bug #207282.
einfo "Creating the Class Data Sharing archives"
"${ddest}/bin/java" -server -Xshare:dump || die

# Remove empty dirs we might have copied.
find "${D}" -type d -empty -exec rmdir -v {} + || die

if use x64-macos ; then
local lib
for lib in lib{decora_sse,glass,prism_{common,es2,sw}}.dylib ; do
ebegin "Fixing self-reference of ${lib}"
install_name_tool \
-id "${EPREFIX}${dest}"/lib/${lib} \
"${ddest}"/lib/${lib} || die
eend $?
done
fi

use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-9.env.sh
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
java-vm-2_pkg_postinst

if ! use headless-awt && ! use javafx ; then
ewarn "You have disabled the javafx flag. Some modern desktop Java applications"
ewarn "require this and they may fail with a confusing error message."
fi

if use gentoo-vm ; then
ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
ewarn "recognised by the system. This will almost certainly break things."
else
ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
ewarn "will not be recognised by the system. For example, simply calling"
ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
ewarn "fully supports Java 9. This JDK must therefore be invoked using its"
ewarn "absolute location under ${EPREFIX}/opt/${P}."
fi
}

pkg_postrm() {
gnome2_icon_cache_update
java-vm-2_pkg_postrm
}

0 comments on commit 3ec59c9

Please sign in to comment.