Skip to content

Commit

Permalink
www-client/opera-beta: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.16, Repoman-2.3.6
  • Loading branch information
Jeroen Roovers committed Dec 8, 2017
1 parent 80600f6 commit 3fdc5d8
Show file tree
Hide file tree
Showing 2 changed files with 115 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/opera-beta/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST opera-beta_50.0.2762.14_amd64.deb 52020480 BLAKE2B 8ae8b0af0bae23f3570bb370a7d584216f9c8245016835c5add0974a9bc280c922d9eb186f4cb30f3b03ec83f54a9ecd0b246dc6ae4f36598bd8347fd8d40585 SHA512 b8a225230923018b3176a422f30478e9189b7642121af1e2434a03cc5bbaac9ebaa92c72ec7636dfa121d2e161eb9780fea37b0a5e00feac0ded2fcf648183b3
DIST opera-beta_50.0.2762.18_amd64.deb 52047108 BLAKE2B f0e6c2d7ca3bf6bc9a2e982a27c9e8d3804b0f4623eae751f3485f4d3898592ba9463e733288d9e1b8c823127a575a2a76a874e77b2211e20057b56fd83c7eb1 SHA512 a9a1f5ac8851a03cdee383109525dcc933826430f465744cd49d97837754058fec79a2ea577806a0df4d4b4fa666e33b6d8a2bf5131f82f20bc885d698c15c10
DIST opera-beta_50.0.2762.28_amd64.deb 52741080 BLAKE2B 68d9cd8c90312a1d69f6c9c15d75de7d2cc92d4746f46694f84fb080090382d911a7f14b16c4c24edd88314aa9ac850fb9125a9cf06254cebbf00a77dc471a84 SHA512 74e6f1f8feb7539a2a4c78ede571a6266c7c0a24c2eb33c21b45025b24e3f08b894181525a4d1b2ff96c0e350b5a65c46a55d6c0845f631db1c46f5592bcfb59
114 changes: 114 additions & 0 deletions www-client/opera-beta/opera-beta-50.0.2762.28.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,114 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
CHROMIUM_LANGS="
be bg bn ca cs da de el en-GB es-419 es fil fi fr-CA fr hi hr hu id it
ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
zh-CN zh-TW
"
inherit chromium-2 gnome2-utils multilib unpacker xdg-utils

DESCRIPTION="A fast and secure web browser"
HOMEPAGE="http://www.opera.com/"
LICENSE="OPERA-2014"
SLOT="0"
SRC_URI_BASE="
http://download1.operacdn.com/pub/
http://download2.operacdn.com/pub/
http://download3.operacdn.com/pub/
http://download4.operacdn.com/pub/
"
SRC_URI="amd64? ("
for uri in ${SRC_URI_BASE}; do
SRC_URI+="
"${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
"
done
SRC_URI+=")"
KEYWORDS="~amd64"

RDEPEND="
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype
net-misc/curl
net-print/cups
sys-apps/dbus
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/libnotify
x11-libs/pango[X]
"

QA_PREBUILT="*"
S=${WORKDIR}
OPERA_HOME="usr/$(get_libdir)/${PN}"

src_unpack() {
unpack_deb ${A}
}

src_prepare() {
case ${ARCH} in
amd64)
mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
rm -r usr/lib || die
;;
x86)
mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
;;
esac

rm usr/bin/${PN} || die

rm usr/share/doc/${PN}/copyright || die
mv usr/share/doc/${PN} usr/share/doc/${PF} || die

pushd "${OPERA_HOME}/localization" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die

sed -i \
-e 's|^TargetEnvironment|X-&|g' \
usr/share/applications/${PN}.desktop || die
}

src_install() {
mv * "${D}" || die
dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit 3fdc5d8

Please sign in to comment.