Skip to content

Commit

Permalink
dev-util/codeblocks: Version bump (bug #576730).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
Signed-off-by: Ryan Hill <[email protected]>
  • Loading branch information
dirtyepic committed Jun 24, 2016
1 parent b6bc8d8 commit 3ff560a
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/codeblocks/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST codeblocks_13.12-1.tar.gz 17221056 SHA256 772450046e8c8ba2ea0086acf433a46b83e6254fae64df9c8ca132a22f949610 SHA512 f09ab25579a4c9addcebdcc748a23963a52751853f4a1c15da10196d522f94bb17e01b2470b96d4470f5fd98725f7760e3923762c2217bcc48051eb9f7286f58 WHIRLPOOL cdf674bb9febd0d25ccfe84027b0c33f5fe9c5f1d19a1b32650487b71a6f110ee0657eaf67dceb758b192b5e5d3c2dd314f1a696491d7a70d0b334fd31a17ee3
DIST codeblocks_16.01.tar.gz 20250097 SHA256 30fb9d206df4ab3c2e2fec2451a0a7c9723bfed9a673cc9be71e881c529d5a03 SHA512 496ff2dbcf9a8248fa9f1060d50567d1fc6480cc9d8fc9f7d2cd532c82f4344deafe9b43f2b17d2510c74851e21acf2ca90d5cc7b61237d69a17e78e9907a63a WHIRLPOOL b908c7af182d37fc3ab0f2640f4b6033169cdc7964e276df9e57627806b156ba7acba25c43983ecfe2a0aeb3ef7e66652e4f2600e978599116b4d1c472866126
41 changes: 41 additions & 0 deletions dev-util/codeblocks/codeblocks-16.01.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"
WX_GTK_VER="2.8"

inherit eutils wxwidgets

DESCRIPTION="The open source, cross platform, free C++ IDE"
HOMEPAGE="http://www.codeblocks.org/"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
SRC_URI="mirror://sourceforge/codeblocks/${P/-/_}.tar.gz"

IUSE="contrib debug pch static-libs"

S="${WORKDIR}/${P}.release"

RDEPEND="app-arch/zip
x11-libs/wxGTK:${WX_GTK_VER}[X]
contrib? (
app-text/hunspell
dev-libs/boost:=
dev-libs/libgamin
)"
DEPEND="${RDEPEND}
virtual/pkgconfig"

src_configure() {
touch "${S}"/revision.m4 -r "${S}"/acinclude.m4

setup-wxwidgets
econf \
--with-wx-config="${WX_CONFIG}" \
$(use_enable debug) \
$(use_enable pch) \
$(use_enable static-libs static) \
$(use_with contrib contrib-plugins all)
}

0 comments on commit 3ff560a

Please sign in to comment.