forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-radio/wsjtx: Minor bug fix release
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <[email protected]>
- Loading branch information
Showing
2 changed files
with
81 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST wsjtx-2.5.0.tgz 25180010 BLAKE2B 09a50f8bbaca4fa6883ad335a6eb3e0d60d3e20382140ab69e3165ba4a38c9e96b059831db9a28452b15f5a0b98118e1269f3484ac8f375525135236b9d7ce02 SHA512 d5f801c9ec038a84d5b12a3843de9af7bbd6d628bd5eb8d3dd1e1621f04b319f9cc2ed01c882bf09ad3801800ee1b1fbeb49c8a9f991a2c03f3170ac192a6017 | ||
DIST wsjtx-2.5.1.tgz 25249461 BLAKE2B fe858e4a21434c7357aa5baab8f4aff206a22bec7305b2d7c6a3860a389ca19779f4775a5618c046b25a71006a882f7a33b30baebe6e848182bd434ff82bb9aa SHA512 bce84766ea1eb13e899ccfc252ee3bcdb6f1d50afa6b312b0509d1eea8e5dcfc958c772fee2a2c40d43058e06ecda798fa9136252e3de0c4a40df27217a4b362 | ||
DIST wsjtx-2.5.2.tgz 25246974 BLAKE2B ada5fc73a600477fa7f1f68c9c8c53e26c56d60aea1c28edc8c35e4ff67a309bf61e82f58c93c05a24c08ed7e77419c2a6ef6862b7cac059cccbebe66512afaf SHA512 cdccbb824614d391aa8f750e3c7e47d1fe8a9704f50d8a361e8741fadea971683383d9dfe0456c674b4584a47eb9a0fdce9c36a608d164de5ae98538e9b83705 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,80 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
inherit cmake flag-o-matic | ||
|
||
MY_P=${P/_/-} | ||
|
||
DESCRIPTION="Weak signal ham radio communication" | ||
HOMEPAGE="http://physics.princeton.edu/pulsar/K1JT/wsjtx.html" | ||
SRC_URI="mirror://sourceforge/wsjt/${MY_P}.tgz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc" | ||
|
||
RDEPEND=" | ||
dev-libs/boost:=[nls,python] | ||
dev-qt/qtcore:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtmultimedia:5 | ||
dev-qt/qtnetwork:5 | ||
dev-qt/qtwidgets:5 | ||
dev-qt/qtconcurrent:5 | ||
dev-qt/qtserialport:5 | ||
dev-qt/qtsql:5 | ||
dev-qt/qttest:5 | ||
dev-qt/qtprintsupport:5 | ||
virtual/libusb:1 | ||
>=media-libs/hamlib-4.0:= | ||
media-libs/portaudio | ||
sci-libs/fftw:3.0[threads,fortran] | ||
virtual/fortran | ||
app-text/asciidoc | ||
doc? ( dev-ruby/asciidoctor )" | ||
DEPEND="${RDEPEND} | ||
dev-qt/linguist-tools | ||
" | ||
|
||
S=${WORKDIR}/wsjtx | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-2.0.1-hamlib.patch" | ||
"${FILESDIR}/${PN}-2.3.0-drop-docs.patch" | ||
"${FILESDIR}/${PN}-2.1.2-qt_helpers.patch" | ||
"${FILESDIR}/${PN}-2.2.0-werror.patch" | ||
"${FILESDIR}/${PN}-clang.patch" ) | ||
|
||
DOCS=( AUTHORS BUGS NEWS README THANKS ) | ||
|
||
src_unpack() { | ||
unpack ${A} | ||
unpack "${WORKDIR}/${MY_P}/src/wsjtx.tgz" | ||
} | ||
|
||
src_prepare() { | ||
sed -i -e "s/COMMAND \${GZIP_EXECUTABLE}/# COMMAND/" \ | ||
manpages/CMakeLists.txt || die | ||
eapply_user | ||
cmake_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DWSJT_GENERATE_DOCS="$(usex doc)" | ||
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}" | ||
) | ||
append-ldflags -no-pie | ||
cmake_src_configure | ||
} | ||
|
||
src_compile() { | ||
cmake_src_compile | ||
} | ||
|
||
src_install() { | ||
cmake_src_install | ||
rm "${D}"/usr/bin/rigctl{,d}-wsjtx || die | ||
rm "${D}"/usr/share/man/man1/rigctl{,d,com}-wsjtx.1 || die | ||
} |