Skip to content

Commit

Permalink
net-misc/bridge-utils: Bump to version 1.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 1, 2017
1 parent 92704c4 commit 40429f3
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/bridge-utils/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST bridge-utils-1.5.tar.gz 33243 SHA256 42f9e5fb8f6c52e63a98a43b81bd281c227c529f194913e1c51ec48a393b6688 SHA512 4e525fbd3defb509664ef3b728d9e5edfb92beaebdb5d7733d8203fb38cb3f4bb54d02dc1e28813889a2ee19c78b9b47da6d99c8032481a7fd7f104658dea7c3 WHIRLPOOL f11eb95ae9b562cb301bb1f657d87878f0a0729a2129b90fa5957747f078f3afe2ebdadd1eb7ea4a59e544acc8194cf1744126db9ba3f3704210bc18ee3480fa
DIST bridge-utils-1.6.tar.xz 29904 SHA256 cc67efb5d5fb8928a6569b3fade2b4042ec17da04678dab127d96b46489e26c8 SHA512 b2ed39bc67349b7b91f2068cb505c0e3c89a8797d61e3d97ff957796cfe5fcef2c26dd788bd4215f628d69a4c8592377f4e632c3e181e87af3eaa238d8741e02 WHIRLPOOL 29e25c79c4abcf33917333b872fa0d49600a87c7393ee99a9c3f97917698d15e5c44fff781b9013d91d46958273fa9dc5745281bdca3f0177733ade8bf7e4a6c
52 changes: 52 additions & 0 deletions net-misc/bridge-utils/bridge-utils-1.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools linux-info toolchain-funcs

DESCRIPTION="Tools for configuring the Linux kernel 802.1d Ethernet Bridge"
HOMEPAGE="http://bridge.sourceforge.net/"
#SRC_URI="mirror://sourceforge/bridge/${P}.tar.gz"
SRC_URI="mirror://kernel/linux/utils/net/${PN}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="selinux"

DEPEND="virtual/os-headers"
RDEPEND="selinux? ( sec-policy/selinux-brctl )"

CONFIG_CHECK="~BRIDGE"
WARNING_BRIDGE="CONFIG_BRIDGE is required to get bridge devices in the kernel"

get_headers() {
CTARGET=${CTARGET:-${CHOST}}
dir=/usr/include
tc-is-cross-compiler && dir=/usr/${CTARGET}/usr/include
echo "${dir}"
}

src_prepare() {
default
eautoreconf
}

src_configure() {
# use santitized headers and not headers from /usr/src
local myeconfargs=(
--prefix=/
--libdir=/usr/$(get_libdir)
--includedir=/usr/include
--with-linux-headers="$(get_headers)"
)
econf "${myeconfargs[@]}"
}

src_install () {
emake install DESTDIR="${D}"
dodoc AUTHORS ChangeLog README THANKS TODO \
doc/{FAQ,FIREWALL,HOWTO,PROJECTS,RPM-GPG-KEY,SMPNOTES,WISHLIST}
[ -f "${ED%/}"/sbin/brctl ] || die "upstream makefile failed to install binary"
}

0 comments on commit 40429f3

Please sign in to comment.