Skip to content

Commit

Permalink
dev-vcs/git-big-picture: py3.10 + DISTUTILS_USE_SETUPTOOLS
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/818781
Signed-off-by: Sebastian Pipping <[email protected]>
Package-Manager: Portage-3.0.23, Repoman-3.0.3
  • Loading branch information
hartwork committed Oct 23, 2021
1 parent 45924d8 commit 406b969
Showing 1 changed file with 39 additions and 0 deletions.
39 changes: 39 additions & 0 deletions dev-vcs/git-big-picture/git-big-picture-1.1.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PYTHON_COMPAT=( python3_{7..10} )

inherit distutils-r1

DESCRIPTION="Visualization tool for Git repositories"
HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

DEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-util/cram[${PYTHON_USEDEP}]
)
"
# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
# since they are invoked using subprocess
RDEPEND="
dev-vcs/git
media-gfx/graphviz[svg]
"

RESTRICT="!test? ( test )"

python_test() {
pytest -vv test.py || die "Tests fail with ${EPYTHON}"

distutils_install_for_testing
cram test.cram || die "Tests fail with ${EPYTHON}"
}

0 comments on commit 406b969

Please sign in to comment.