Skip to content

Commit

Permalink
app-emulation/qemu: version bump to 3.1.0
Browse files Browse the repository at this point in the history
 - use RESTRICT=strip, bug #651422

 - switch to tar.xz, bug #666726

 - add missing use constraints, bug #664474

   qemu_softmmu_targets_riscv32? ( fdt )
   qemu_softmmu_targets_riscv64? ( fdt )

 - 3.1.0 already contains patches for CVE-2018-15746

 - applied patch for CVE-2018-20123

 - disable bt subsystem entirely as a "workaround" for CVE-2018-19665.

   Upstream deprecated the subsystem in November and states that it had
   been dysfunctional for years with likely no users.

Bug: https://bugs.gentoo.org/664740
Bug: https://bugs.gentoo.org/672346
Bug: https://bugs.gentoo.org/673108
Closes: https://bugs.gentoo.org/651422
Closes: https://bugs.gentoo.org/664474
Closes: https://bugs.gentoo.org/666726
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Matthias Maier <[email protected]>
  • Loading branch information
tamiko committed Dec 19, 2018
1 parent 2fa4699 commit 40e4d2a
Show file tree
Hide file tree
Showing 6 changed files with 860 additions and 3 deletions.
1 change: 1 addition & 0 deletions app-emulation/qemu/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST qemu-2.12.0.tar.bz2 41196232 BLAKE2B f258e570558249ea647c3571908f90b8bacdce
DIST qemu-2.12.1-patches-r1.tar.xz 3648 BLAKE2B 07908004d0b56e60274cb59d4163770290d8fa6e31646e7d96db08427a219638ac53bdd988c9557471b95321a72982d740a29778d843652274a126737a0a6c00 SHA512 1c7768c14a8e168053f0322554214ba59932a9fa23c982b06dbb1b8fdcfc280ae1d97b20244600f357485bfbcb9ad8bd7968787550c8a4e5e243ac8502eff05e
DIST qemu-2.12.1.tar.bz2 41192583 BLAKE2B ff903a5850e406ab542ad1a84300852599fa9c199e0f3290e4d6ddad5284192577351278a18dd5706463b08e817b49340989a35987a04672f7cede2097d1d18d SHA512 4c85e6180bf7ec61c0bdddb20e104a7c93fe6b1de27f6aa50d75633eb78491cb844798a9e3f536245eff7b4ebe9a6227f5f66b418ced44095b8e59c5cb33d4cd
DIST qemu-3.0.0.tar.bz2 41491935 BLAKE2B 715ccca4fced730425eb5c24a78d89d2ab59f64007e0fc199d78c31c6ab72b5a0dbcf1840f214774c711d679c4166996790e93b2416c7d4f323d5b93ffa862ac SHA512 b82b78a063d60fa1372d9400934b47250138c438050d974113b1b2ea433eea0531be6cda1e82d14fcb3bc4ed35657703f62d9aedc095cb8d64badc65c3609ee5
DIST qemu-3.1.0.tar.xz 36070104 BLAKE2B 9ed7d1b3256d84f2b73d61763e20f5e4bc5b47d56e4e0d56cf4c29cd25669457b0f08e90d7255589c9666400bb310df3dba3b9290232cad18057b20f08013a3b SHA512 7e8dae823937cfac2f0c60406bd3bdcb89df40313dab2a4bed327d5198f7fcc68ac8b31e44692caa09299cc71256ee0b8c17e4f49f78ada8043d424f5daf82fe
35 changes: 35 additions & 0 deletions app-emulation/qemu/files/qemu-3.1.0-CVE-2018-20123.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From: Prasad J Pandit <address@hidden>

If during pvrdma device initialisation an error occurs,
pvrdma_realize() does not release memory resources, leading
to memory leakage.

Reported-by: Li Qiang <address@hidden>
Signed-off-by: Prasad J Pandit <address@hidden>
---
hw/rdma/vmw/pvrdma_main.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/hw/rdma/vmw/pvrdma_main.c b/hw/rdma/vmw/pvrdma_main.c
index 8a03ab4669..b65f8662df 100644
--- a/hw/rdma/vmw/pvrdma_main.c
+++ b/hw/rdma/vmw/pvrdma_main.c
@@ -579,7 +579,7 @@ static void pvrdma_shutdown_notifier(Notifier *n, void *opaque)

static void pvrdma_realize(PCIDevice *pdev, Error **errp)
{
- int rc;
+ int rc = 0;
PVRDMADev *dev = PVRDMA_DEV(pdev);
Object *memdev_root;
bool ram_shared = false;
@@ -655,6 +655,7 @@ static void pvrdma_realize(PCIDevice *pdev, Error **errp)

out:
if (rc) {
+ pvrdma_fini(pdev);
error_append_hint(errp, "Device fail to load\n");
}
}
--
2.19.2
2 changes: 1 addition & 1 deletion app-emulation/qemu/files/qemu-binfmt.initd.head
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Enable automatic non-native program execution by the kernel.
Expand Down
2 changes: 1 addition & 1 deletion app-emulation/qemu/qemu-2.12.0-r3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
Expand Down
2 changes: 1 addition & 1 deletion app-emulation/qemu/qemu-2.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
Expand Down
Loading

0 comments on commit 40e4d2a

Please sign in to comment.