Skip to content

Commit

Permalink
dev-util/codeblocks: update codeblocks-9999.ebuild
Browse files Browse the repository at this point in the history
Add updated codeblocks-9999.ebuild that is synced with codeblocks-17.12-r1.ebuild
(has updated dependencies) and allow to build Codeblocks from svn trunk.

The USE-flag 'fortran' removed in this ebuild-file as FortranProject plugin sources
downloads from external svn repo and could requires from time to time changes
of the autotools script patch to build successfully.
  • Loading branch information
band-a-prend authored and leio committed Jul 14, 2018
1 parent 7ebb127 commit 4103b7a
Showing 1 changed file with 27 additions and 17 deletions.
44 changes: 27 additions & 17 deletions dev-util/codeblocks/codeblocks-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,36 +1,39 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
EAPI=6

WX_GTK_VER="3.0"

inherit autotools eutils subversion wxwidgets
inherit autotools gnome2-utils subversion wxwidgets xdg-utils

DESCRIPTION="The open source, cross platform, free C++ IDE"
DESCRIPTION="The open source, cross platform, free C, C++ and Fortran IDE"
HOMEPAGE="http://www.codeblocks.org/"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
SRC_URI=""
ESVN_REPO_URI="svn://svn.code.sf.net/p/${PN}/code/trunk"

IUSE="contrib debug pch static-libs"
IUSE="contrib debug pch"

RDEPEND="app-arch/zip
x11-libs/wxGTK:${WX_GTK_VER}[X]
contrib? (
app-admin/gamin
app-text/hunspell
dev-libs/boost:=
dev-libs/libgamin
)"

DEPEND="${RDEPEND}
>=dev-libs/tinyxml-2.6.2-r3
>=dev-util/astyle-3.1-r2:0/3.1
virtual/pkgconfig"

src_unpack() {
subversion_src_unpack
}
PATCHES=( "${FILESDIR}"/codeblocks-17.12-nodebug.diff )

src_prepare() {
default
# Let's make the autorevision work.
subversion_wc_info
CB_LCD=$(LC_ALL=C svn info "${ESVN_WC_PATH}" | grep "^Last Changed Date:" | cut -d" " -f4,5)
Expand All @@ -40,21 +43,28 @@ src_prepare() {
}

src_configure() {
need-wxwidgets unicode
setup-wxwidgets

econf \
--with-wx-config="${WX_CONFIG}" \
--disable-static \
$(use_enable debug) \
$(use_enable pch) \
$(use_enable static-libs static) \
$(use_with contrib contrib-plugins all)
}

src_compile() {
emake clean-zipfiles
emake
pkg_postinst() {
if [[ ${WX_GTK_VER} == "3.0" || ${WX_GTK_VER} == "3.0-gtk3" ]]; then
elog "The symbols browser is disabled due to it causing crashes."
elog "For more information see https://sourceforge.net/p/codeblocks/tickets/225/"
fi

xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

src_install() {
default
prune_libtool_files
pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

0 comments on commit 4103b7a

Please sign in to comment.