Skip to content

Commit

Permalink
dev-ruby/unf_ext: add 0.0.7.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
graaff committed Apr 13, 2017
1 parent 9cb17fb commit 413a13c
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/unf_ext/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST unf_ext-0.0.7.1.gem 392192 SHA256 ab58d1a808d38872817bea89fc3f055bfc250af48d9653425e35c7c18caec253 SHA512 06239dc5870ad0f345266b12ad6ed9508ab731dfd37b450d0e1eae1ef8e8301f8ad1ef7fffbbcf69b56b0af5aa257ea279dda3a252bdf397d11949e9885db3d4 WHIRLPOOL 4d5d8c6efb46bb46b65967101389b5b7414bfa507d591e29dfb9d8c354555b9b92a997f19b68e0d4aa58143bf836849f152dafc2936b13a11cac74d7063f3d16
DIST unf_ext-0.0.7.2.gem 392192 SHA256 e8fa13d09880f8d06d30a86f929a38ba0af6abe61272927a49e6796aee1aa111 SHA512 99e1cada3cc51baf52010b7569f68eff168dfb4c691645c88625738513258191e586e5d99f5ba7f528ce677fdec77a08510f77d9bf2c9234c68ac239f270fbf6 WHIRLPOOL 2e932abce52f87709dbf5f25ba8a7a32bd55410ba10b620db4d23a41855faf0da3486674ea7e9fb11849f9621d0fdbab8739c0486278026ba9e8f27ae47f5332
DIST unf_ext-0.0.7.3.gem 398848 SHA256 11d15d7bb7ae7f1128abc6043a375aece8af907f878e51b39027b30e183367a8 SHA512 cfae54a226004dff99da2a21615a3d54d016db552cec18730e2609ac0838e03db2f877a4f161d3a2bece644dd9b4f3a450caa86d76abe68638cfda33718a72a5 WHIRLPOOL ecf173daaaa49b7044d70162371233ae9b4ae8c6837f4e3a629f44528aed14e158af726791e3b6ee162f49697eb068c9be6ca5a1cb40d046c2a9e6cd299409cd
45 changes: 45 additions & 0 deletions dev-ruby/unf_ext/unf_ext-0.0.7.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

USE_RUBY="ruby21 ruby22 ruby23 ruby24"

RUBY_FAKEGEM_RECIPE_TEST="none"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"

RUBY_FAKEGEM_EXTRADOC="README.md"

inherit ruby-fakegem multilib

DESCRIPTION="Unicode Normalization Form support library for CRuby"
HOMEPAGE="https://github.com/knu/ruby-unf_ext"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="doc test"

ruby_add_bdepend "
test? (
>=dev-ruby/test-unit-2.5.1-r1
)"

all_ruby_prepare() {
sed -i -e '/bundler/,/end/ s:^:#:' Rakefile test/helper.rb || die
}

each_ruby_configure() {
${RUBY} -Cext/unf_ext extconf.rb || die
}

each_ruby_compile() {
emake -Cext/unf_ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
cp ext/unf_ext/*$(get_modname) lib/ || die
}

each_ruby_test() {
ruby-ng_testrb-2 test/test_*.rb
}

0 comments on commit 413a13c

Please sign in to comment.