Skip to content

Commit

Permalink
media-libs/gst-plugins-good: fix building gst-plugins-good-0.10.31 wi…
Browse files Browse the repository at this point in the history
…th clang

Gentoo-Bug: https://bugs.gentoo.org/558080

Package-Manager: portage-2.2.26
  • Loading branch information
austin987 committed Jun 2, 2016
1 parent 5f3838b commit 4231143
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
--- gst/goom/mmx.h.orig 2011-12-11 19:48:11.000000000 +0100
+++ gst/goom/mmx.h 2013-02-08 00:54:14.000000000 +0100
@@ -715,13 +715,13 @@ void zoom_filter_xmmx (int prevX, int pr
{ \
printf("emms()\n"); \
__asm__ __volatile__ ("emms" \
- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
+ "st", "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
}

#else

#define emms() __asm__ __volatile__ ("emms"::: \
- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
+ "st", "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")

#endif

61 changes: 61 additions & 0 deletions media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

GST_ORG_MODULE="gst-plugins-good"
inherit eutils flag-o-matic gstreamer

DESCRIPTION="Basepack of plugins for gstreamer"
HOMEPAGE="https://gstreamer.freedesktop.org/"

LICENSE="LGPL-2.1+"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="+orc"

RDEPEND="
>=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
>=media-libs/gstreamer-0.10.36:${SLOT}[${MULTILIB_USEDEP}]
>=media-libs/gst-plugins-base-0.10.36:${SLOT}[${MULTILIB_USEDEP}]
>=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.12
!<media-libs/gst-plugins-bad-0.10.22:${SLOT}
"
# audioparsers and qtmux moves

src_configure() {
# gst doesnt handle optimisations well
strip-flags
replace-flags "-O3" "-O2"
filter-flags "-fprefetch-loop-arrays" # see bug 22249

multilib-minimal_src_configure
}

src_prepare() {
epatch "${FILESDIR}/${PN}-0.10-clang.patch"
}

multilib_src_configure() {
# Always enable optional bz2 support for matroska
# Always enable optional zlib support for qtdemux and matroska
# Many media files require these to work, as some container headers are often
# compressed, bug #291154
gstreamer_multilib_src_configure \
--enable-bz2 \
--enable-zlib \
--disable-examples \
--with-default-audiosink=autoaudiosink \
--with-default-visualizer=goom
}

multilib_src_install_all() {
DOCS="AUTHORS ChangeLog NEWS README RELEASE"
einstalldocs
prune_libtool_files --modules
}

0 comments on commit 4231143

Please sign in to comment.