Skip to content

Commit

Permalink
dev-util/gertty: add git master version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Apr 22, 2019
1 parent 04a0290 commit 42480d1
Showing 1 changed file with 43 additions and 0 deletions.
43 changes: 43 additions & 0 deletions dev-util/gertty/gertty-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

DESCRIPTION="Gertty is a console-based interface to the Gerrit Code Review system."
HOMEPAGE="https://pypi.org/project/gertty/"
if [[ ${PV} == *9999 ]];then
inherit git-r3
EGIT_REPO_URI="https://opendev.org/ttygroup/gertty"
EGIT_BRANCH="master"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi

LICENSE="Apache-2.0"
SLOT="0"
SLOT="0"
IUSE=""

CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
!~dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
>=dev-python/git-python-0.3.7[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
<dev-python/requests-3.0.0[${PYTHON_USEDEP}]
dev-python/ordereddict[${PYTHON_USEDEP}]
>=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
>=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]
>=dev-python/ply-3.4[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"

0 comments on commit 42480d1

Please sign in to comment.