Skip to content

Commit

Permalink
media-libs/elementary: version bump to 1.17.0 #573784
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Feb 21, 2016
1 parent a588965 commit 42b7752
Show file tree
Hide file tree
Showing 3 changed files with 60 additions and 4 deletions.
1 change: 1 addition & 0 deletions media-libs/elementary/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST elementary-1.12.2.tar.bz2 16726431 SHA256 c6aa5e83224400babdd2a6ed848eeb09aa9bed2e1f573619d4d8c0dbf29fcd12 SHA512 05c9fb012bd933fe52978d0bdec7d80be06a54531d6c026de0cd32c7ba218c2c9960ed6c5f5aa94360c88a4465dbd3b8df7d92e73bc6bb754493b44825858232 WHIRLPOOL 97666a5072e280a613f21b3c32566b6a47a0d5a46fbe4983ec3e40c35bba6bd1f5d8f4d09557023494a9eaa89dc14711b8cc007d81e4c19881601955c1acf3df
DIST elementary-1.15.2.tar.xz 18514048 SHA256 523c3073210b611817d0f56aa8348962ec757282f9f7dfde93825afa164a0f3f SHA512 7ee796898aee7667e0ae6e8e7d1a604287fc9b009a7a3f4ab75c15b10160e0a38975dfbf6586c20ad2fdc8075dd867287d4d5617ad6b6be2e522c74beb03ce38 WHIRLPOOL 6d42e6063c8d697d237b003781f33e6b3bf562c2785458cd3cf1cf84319325ac1ff39704e33bae641610b1ff669b2fe115135a5f939eca0314a25ee7a6a6bf0a
DIST elementary-1.16.1.tar.xz 18536148 SHA256 7e3863640a9c6dff91d62a06a3119c6c6682247e4669583033b80c7d608da860 SHA512 fa5dce7c40be55f57e145ee459df5452b946b3701fe61f2f160e90c65720bcb1c24730b6fec9892c51d29af3d2898f38c8cbce83225b00e2aec5a27cb3081a5f WHIRLPOOL 6d0f1d40e91de42eb42552fa6c39578d8577f47e0ee2028f32e4e625b25a32ee229f7129f5ec4b6d54787ff669f8f3b5b0ca26e6334475565440a36f982381cd
DIST elementary-1.17.0.tar.xz 18491592 SHA256 6a6a5883939eab8d87179c7980c0dbd6b53d82bf460a161045a891694d036b2b SHA512 60862e164770a93c0b864f35b5880f8d28f9fec520b7b440935143a14ffc9cd2dacbb650463c2abb7ce364c631509e1ddefce6eb49def1b016a752416d619065 WHIRLPOOL 76499e687908b8c2c885429c614a493b226f5e2d73edc040a5d6e8e287dab3b342b517fa46e4a37ca6560e4a9c617415d8138da1308865aa5d07187d60c7ea61
53 changes: 53 additions & 0 deletions media-libs/elementary/elementary-1.17.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

MY_P=${P/_/-}

if [[ "${PV}" == "9999" ]] ; then
EGIT_SUB_PROJECT="core"
EGIT_URI_APPEND="${PN}"
else
SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
EKEY_STATE="snap"
fi

inherit enlightenment

DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices"
HOMEPAGE="https://trac.enlightenment.org/e/wiki/Elementary"

LICENSE="LGPL-2.1"
IUSE="debug examples fbcon javascript quicklaunch sdl wayland X static-libs"

DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]
javascript? ( net-libs/nodejs )"
RDEPEND="${DEPEND}"

S=${WORKDIR}/${MY_P}

src_configure() {
E_ECONF=(
$(use_enable debug)
$(use_enable doc)
--disable-ecore-cocoa
--disable-ecore-psl1ght
--disable-ecore-win32
--disable-elocation
--disable-emap
--disable-eweather
# broken: make[4]: *** No rule to make target 'prefs_example_01.epb', needed by 'all-am'. Stop
#$(use_enable examples build-examples)
$(use_enable examples install-examples)
$(use_enable fbcon ecore-fb)
$(use_enable javascript js-bindings)
$(use_enable sdl ecore-sdl)
$(use_enable wayland ecore-wl2)
$(use_enable X ecore-x)
$(use_enable quicklaunch quick-launch)
)

enlightenment_src_configure
}
10 changes: 6 additions & 4 deletions media-libs/elementary/elementary-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -20,9 +20,10 @@ DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices"
HOMEPAGE="https://trac.enlightenment.org/e/wiki/Elementary"

LICENSE="LGPL-2.1"
IUSE="debug examples fbcon quicklaunch sdl wayland X static-libs"
IUSE="debug examples fbcon javascript quicklaunch sdl wayland X static-libs"

DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]"
DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]
javascript? ( net-libs/nodejs )"
RDEPEND="${DEPEND}"

S=${WORKDIR}/${MY_P}
Expand All @@ -41,8 +42,9 @@ src_configure() {
#$(use_enable examples build-examples)
$(use_enable examples install-examples)
$(use_enable fbcon ecore-fb)
$(use_enable javascript js-bindings)
$(use_enable sdl ecore-sdl)
$(use_enable wayland ecore-wayland)
$(use_enable wayland ecore-wl2)
$(use_enable X ecore-x)
$(use_enable quicklaunch quick-launch)
)
Expand Down

0 comments on commit 42b7752

Please sign in to comment.