Skip to content

Commit

Permalink
app-admin/eselect: Version bump, removes binutils module, bug 507870.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
ulm committed Aug 13, 2015
1 parent 6a96ff0 commit 43611f9
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/eselect/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST eselect-1.3.8.tar.xz 168040 SHA256 d0c50bfe0faaddc54fc184f698ee74a6029a21f5155c4670a2bea3ead954c138 SHA512 159bf3ddb05b1966318eaf62d09e454a024f8be7ead2300392abbcbaa54ef748a1c4db1b2f96162994bcab43071396eb96a0b47268f04cb8557f8804818da18e WHIRLPOOL 9c4da0bde2ae2b53e8949d59b13498f55ef2c849dcc8cac503a7d0dda2511311d94dfc7aa27a97432f13aa0b430fec0ab280594dc165bbb40e573dce8c8a74b0
DIST eselect-1.4.4.tar.xz 177536 SHA256 120c123eae4a1d03515e94f9efd51af6ff2f09340daf1ada4dc21079df7a937f SHA512 1ed01cf00e3f13aad3e5f844c7086c3dd48398efd76e68cd91cf13b9939f4b48eef8915c5f3926954d158023115ad66ee67c0bc8fc4c9570900a37207674fc8f WHIRLPOOL e56c3ea3e54bdbcfffba3fbbe85b3c824cab796a0bae2680fac962356a2f707783571a9f73e0ea8299098838e593bea77b14edbeaadc372f186c2da2928e9ab5
DIST eselect-1.4.5.tar.xz 175992 SHA256 15beabb4c2afab4f833ceb2a66859849a5c20b8f8d61366ffe4b556a200d5f12 SHA512 d561b66386ac90335041e8fb88dd85cbe98ea32a98eab309a5fb07de1b9fe10c50dcdd03f93632d4bc938c1729ddb0954fa37482eb7856a87c24f41a7bc29a35 WHIRLPOOL e18839e9ff0ea1af03c6246533e72d39f9f7eb61f28d6cec3ff1a571374f23f7d55751c1f20bfb99c40fb44a81b5754b6c92d62c98f6b1b45dc8bf388b54db40
60 changes: 60 additions & 0 deletions app-admin/eselect/eselect-1.4.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=4

inherit eutils bash-completion-r1

DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Eselect"
SRC_URI="http://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"

LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-3.0 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc emacs vim-syntax"

RDEPEND="sys-apps/sed
|| (
sys-apps/coreutils
sys-freebsd/freebsd-bin
app-misc/realpath
)"
DEPEND="${RDEPEND}
app-arch/xz-utils
doc? ( dev-python/docutils )"
RDEPEND="${RDEPEND}
sys-apps/file
sys-libs/ncurses"

PDEPEND="emacs? ( app-emacs/eselect-mode )
vim-syntax? ( app-vim/eselect-syntax )"

src_compile() {
emake
use doc && emake html
}

src_install() {
emake DESTDIR="${D}" install
newbashcomp misc/${PN}.bashcomp ${PN}
dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
use doc && dohtml *.html doc/*

# needed by news module
keepdir /var/lib/gentoo/news
if ! use prefix; then
fowners root:portage /var/lib/gentoo/news
fperms g+w /var/lib/gentoo/news
fi
}

pkg_postinst() {
# fowners in src_install doesn't work for the portage group:
# merging changes the group back to root
if ! use prefix; then
chgrp portage "${EROOT}/var/lib/gentoo/news" \
&& chmod g+w "${EROOT}/var/lib/gentoo/news"
fi
}

0 comments on commit 43611f9

Please sign in to comment.