Skip to content

Commit

Permalink
media-gfx/gnofract4d: version bump to 4.3_p20201029
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/746263
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Signed-off-by: Chris Mayo <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
cjmayo authored and juippis committed Nov 11, 2020
1 parent e88067d commit 43a0370
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/gnofract4d/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gnofract4d-4.0.1_p1.tar.gz 7638038 BLAKE2B c12bade5f219d2d41dc50569c0df315273b0c2a0a6a40543f48f3e4cb766512ed18b979463574db65ac443b1a8dffbcc1f3c9dc04d7c6b89881fdfcfce95c41c SHA512 d7f3a081b3681866d2da911eedab6ec74f22f36d5175a85f93751519e96971cf147b99ddcda32c597283b39e9da4f0fc6a8843331334a18efa3bf459cfd00af5
DIST gnofract4d-4.3_p20200821.tar.gz 18256808 BLAKE2B dbdf69879bd40f1963b88bba35b831d7f6f96afff3d6d62c970324d5af613eb58bc71152245017135a99308857b4861650c46a4c345b73aed734e5bdaf04c524 SHA512 21afcd56521dfa526b49617ec8b1373b41492c22cd44cf7da4c13fef8ae5a6d5b54eb8859eb1e85b34db444a84e672905443576b60f1768c777bce120efa46d4
DIST gnofract4d-4.3_p20201029.tar.gz 18270417 BLAKE2B 82d9f9528c33cf73478fa48d8692617237029944e68d9626d0c39e088b1b6aebc02a8c32a1a0e14c8d115cf3f0434940ec8a8c3d915fc9967b22f7e51353dd6b SHA512 f5844a88c41941429379efe99d1e0593a994a42d600e6e05f722c01c4ced48ceff730bf6bc797e083bd558931d39a31ffe86021eac0f0c6ec0f3047569962e3f
63 changes: 63 additions & 0 deletions media-gfx/gnofract4d/gnofract4d-4.3_p20201029.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_SINGLE_IMPL=1

inherit distutils-r1 optfeature virtualx xdg

COMMIT="3e3893b0ee381098418d7b28997f6b861c53eff1"

DESCRIPTION="A program for drawing beautiful mathematically-based images known as fractals"
HOMEPAGE="https://fract4d.github.io/gnofract4d/"
SRC_URI="https://github.com/fract4d/gnofract4d/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND="
media-libs/libpng:0=
virtual/jpeg"
RDEPEND="${DEPEND}
$(python_gen_cond_dep '
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
')
x11-libs/gtk+:3[introspection]"
BDEPEND="
virtual/pkgconfig
test? (
media-video/ffmpeg[vpx,zlib]
)"

distutils_enable_tests pytest

S="${WORKDIR}/${PN}-${COMMIT}"

src_prepare() {
sed -i -e "s:share/doc/gnofract4d/:share/doc/${PF}/:" setup.py || die
# test_regress.py does not provide pytest with any tests and inspecting it requires dev-python/pillow
rm test_regress.py || die
# tests hanging with virtx
rm fract4dgui/tests/test_{director,gtkfractal}.py || die

distutils-r1_src_prepare
}

python_compile_all() {
if use test; then
ln -s "${BUILD_DIR}"/lib/fract4d/*.so fract4d/ || die
fi
}

src_test() {
virtx distutils-r1_src_test
}

pkg_postinst() {
xdg_pkg_postinst
optfeature "creating videos" media-video/ffmpeg[vpx,zlib]
}

0 comments on commit 43a0370

Please sign in to comment.