Skip to content

Commit

Permalink
media-sound/lilypond: version bump to 2.19.52
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Dec 9, 2016
1 parent b4cbf13 commit 4424e6e
Show file tree
Hide file tree
Showing 2 changed files with 143 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/lilypond/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST lilypond-2.18.2.tar.gz 16027977 SHA256 329d733765b0ba7be1878ae3f457dbbb875cc2840d2b75af4afc48c9454fba07 SHA512 0692f6eb41733076ba7f610cd1e65762f4dfd67307e2ab9e222b140d58ae3a1bb1c6b3be3bcff778d57f161868cf6d57e99bf43bf20f2663d042a07493942ec6 WHIRLPOOL 95db264992a1e425fd1ee53d980941eef554c1784a1adfc105750d82d11664f61207c2b1897b6e99448790131c0715f08401f45b663c420553925596c6fd4b1c
DIST lilypond-2.19.49.tar.gz 17037279 SHA256 cd190de273cfef61a76c7dec74700b1e8a5d0b44cc98d8a11b58325706c6a3ee SHA512 1b1cd356f332994855f67a1dd8d0aef02f0b133d3aa9c91ddba0950b78b1cb4dc243b0926f7ce0ac46677c8b3cd267cd03db965cb26f74928a645c9d358c6ba2 WHIRLPOOL e0ffd3cde364d234b2bc1f75a453cf40412accab69852befe5d6cc81e5e8dbf91afbb1f5bb3c05b43ff0444b7854621edf1a95dfad5dc46c869530b086685242
DIST lilypond-2.19.50.tar.gz 17059560 SHA256 169ad09fac39512c780d917f5b164dc6a1570f19f5516f812df9eb2157224eb3 SHA512 14267d7e0b578b8b32913042438e4087904023860d3ad607faa3a702741176f2cecc019e0b6c5c88132a93696b087f59ede58e96972c877c911d20b89de1ecd2 WHIRLPOOL 1b8f31728541a9fcd1c34f22c544b464dc89c0591938a882097af1f0581e76dfa8ddb7c4f09f31ad4d5df413615f99bc774bd08a0a668879f9449ef9cd8ff8e4
DIST lilypond-2.19.52.tar.gz 17064855 SHA256 77f4a62b2872f7d6813c7e58b9f8680fc4c3434b86f695117d135b5402e90409 SHA512 afdfa6f277235911b8cfb85985df110d740a580d7d8cb3899e682077674e71faaa050dab16d156d78c0e99243ddb59fb20282a3557309f8679ed457563364020 WHIRLPOOL 54882a8d43ce371ad3a27a955cd464a2296a630b7f274235e24373e08eca746535b0f62b8fca62e82ebed8425d8347a310405ee6134a248dc2e29ff9fd686e73
142 changes: 142 additions & 0 deletions media-sound/lilypond/lilypond-2.19.52.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,142 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 )

[[ "${PV}" = "9999" ]] && inherit git-r3
inherit elisp-common autotools python-single-r1

if [[ "${PV}" = "9999" ]]; then
EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
else
SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
fi

DESCRIPTION="GNU Music Typesetter"
HOMEPAGE="http://lilypond.org/"

LICENSE="GPL-3 FDL-1.3"
SLOT="0"
LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
IUSE="debug emacs profile vim-syntax ${LANGS// / linguas_}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND=">=app-text/ghostscript-gpl-8.15
>=dev-scheme/guile-1.8.2:12[deprecated,regex]
media-fonts/tex-gyre
media-libs/fontconfig
media-libs/freetype:2
>=x11-libs/pango-1.12.3
emacs? ( virtual/emacs )
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
app-text/t1utils
dev-lang/perl
dev-libs/kpathsea
>=dev-texlive/texlive-metapost-2013
|| (
>=app-text/texlive-core-2013
>=dev-tex/metapost-1.803
)
virtual/pkgconfig
media-gfx/fontforge[png]
>=sys-apps/texinfo-4.11
>=sys-devel/bison-2.0
sys-devel/flex
sys-devel/gettext
sys-devel/make"

# Correct output data for tests isn't bundled with releases
RESTRICT="test"

DOCS=( DEDICATION HACKING README.txt ROADMAP )

pkg_setup() {
# make sure >=metapost-1.803 is selected if it's installed, bug 498704
if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
einfo "Updating metapost symlink"
eselect mpost update || die
fi
fi

python-single-r1_pkg_setup
}

src_prepare() {
default

if ! use vim-syntax ; then
sed -i 's/vim//' GNUmakefile.in || die
fi

# respect CFLAGS
sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die

for lang in ${LANGS}; do
use linguas_${lang} || rm po/${lang}.po || die
done

# respect AR
sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die

# remove bundled texinfo file (fixes bug #448560)
rm tex/texinfo.tex || die

eautoreconf
}

src_configure() {
# documentation generation currently not supported since it requires a newer
# version of texi2html than is currently in the tree

local myeconfargs+=(
--with-texgyre-dir=/usr/share/fonts/tex-gyre
--disable-documentation
--disable-optimising
--disable-pipe
$(use_enable debug debugging)
$(use_enable profile profiling)
)

has_version ">=dev-scheme/guile-2" && myeconfargs+=( --enable-guile2 )

econf "${myeconfargs[@]}"
}

src_compile() {
default

if use emacs ; then
elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
|| die "elisp-compile failed"
fi
}

src_install () {
emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install

# remove elisp files since they are in the wrong directory
rm -r "${ED}"/usr/share/emacs || die

if use emacs ; then
elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
|| die "elisp-install failed"
elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
fi

python_fix_shebang "${ED}"

einstalldocs
}

pkg_postinst() {
use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 4424e6e

Please sign in to comment.