Skip to content

Commit

Permalink
games-emulation/dosbox: opengl USE flag should require libsdl[opengl]
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/608366
Package-Manager: Portage-2.3.53, Repoman-2.3.12
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
chewi committed Dec 29, 2018
1 parent f06b9fe commit 442ebfd
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 2 deletions.
70 changes: 70 additions & 0 deletions games-emulation/dosbox/dosbox-0.74_p20160629-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools desktop flag-o-matic

PATCH=3989
GLIDE_PATCH=3722fc563b737d2d7933df6a771651c2154e6f7b

DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
SRC_URI="mirror://gentoo/dosbox-code-0-${PATCH}-dosbox-trunk.zip
glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
IUSE="alsa debug glide hardened opengl"

RDEPEND="alsa? ( media-libs/alsa-lib )
glide? ( media-libs/openglide )
opengl? ( virtual/glu virtual/opengl )
debug? ( sys-libs/ncurses:0 )
media-libs/libpng:0
media-libs/libsdl[joystick,opengl?,video,X]
media-libs/sdl-net
media-libs/sdl-sound"
DEPEND="${RDEPEND}
app-arch/unzip"

S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk

PATCHES=(
"${FILESDIR}"/${PN}-0.74-gcc46.patch
)

src_prepare() {
use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff
default
eautoreconf
}

src_configure() {
use glide && append-cppflags -I"${EPREFIX}"/usr/include/openglide

econf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
$(use_enable debug) \
$(use_enable opengl)
}

src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
}

pkg_postinst() {
if use glide; then
elog "You have enabled unofficial Glide emulation. To use this, symlink"
elog "or copy ${EPREFIX}/usr/share/openglide/glide2x-dosbox.ovl to your game's"
elog "directory and add the following to your DOSBox configuration."
elog ""
elog "[glide]"
elog "glide=true"
fi
}
4 changes: 2 additions & 2 deletions games-emulation/dosbox/dosbox-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -28,7 +28,7 @@ DEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/glu virtual/opengl )
debug? ( sys-libs/ncurses:0 )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/libsdl[joystick,opengl?,video,X]
media-libs/sdl-net
media-libs/sdl-sound"
RDEPEND=${DEPEND}
Expand Down

0 comments on commit 442ebfd

Please sign in to comment.