Skip to content

Commit

Permalink
app-admin/filebeat: bump to 6.3.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.45, Repoman-2.3.10
Closes: gentoo#9518
  • Loading branch information
hydrapolic authored and Zlogene committed Aug 28, 2018
1 parent 4e6c473 commit 442f98d
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/filebeat/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST filebeat-5.6.10.tar.gz 18211551 BLAKE2B 5ed3a3d63fc758757cdb30e999a10bee15c
DIST filebeat-6.1.1.tar.gz 17061456 BLAKE2B 5a5d23618f8140f3815c499305d99ae3dc4c4caa49535043040387922f924ee49a9494b5139f34a70d74173d97332b92909fc74e2f91a2fc0f288ef5d1493ade SHA512 54e85cfce58ba724f6b2892f115ac9ef5b1bb89ce8dc6f2a977e50ccfc07cf95fc578e46e0cadd96acd90c59f4b01446851b93c519afa094ff6dcdb7e716219a
DIST filebeat-6.2.4.tar.gz 19466271 BLAKE2B 417f1db19b7fdd9bcf66f2c3dcdf2aaa6be9ba5edff1c97a0b8f4a5d7953ef27bcbd860e097fb40e67b3b42b795b684dabb2995eee572243831f749a7184b625 SHA512 49293e28e4ca769a88f7b889ea888a559ae7e142698714e24bf5519d00c2030237cac591590aa284f17792906a6137333173716ddf5db4496217f8b5a054b19c
DIST filebeat-6.3.1.tar.gz 20915568 BLAKE2B 048898bc4520c0dc2a0aa5257149ecb75abc0b52d9a8cae63fdfe9fc8c329b3fa30d7277ae0cb916a86477d60e82b63839956cfa7a1985961c5ee5f6622b9f83 SHA512 1c03cc8fd3b968ade678cf2290fd7bd8fed2f9daa64cd550455567296ff51517b502b54e1b2413820c25cf899b7759662c9c18278c78a2568c74a26841f5f525
DIST filebeat-6.3.2.tar.gz 20923316 BLAKE2B 70ac7e574f94a6141a7c6a1bd0af45ddbda3d01d6ea006c90ea341d2df03cac320d53496833cace3b394b9433251ea68a248dafdc8e28a85a6014314d5a2f3c4 SHA512 3d6ed03c9286bc7784444ad979b1398fcd70d870be184f912202ee5fab7c0ff23df639f445ec14cfcfd4d41ef648f33e88c2959f3c5f966fd3986884a223623a
66 changes: 66 additions & 0 deletions app-admin/filebeat/filebeat-6.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
HOMEPAGE="https://www.elastic.co/products/beats"
SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="test"

DEPEND=">=dev-lang/go-1.10.3"
RDEPEND="!app-admin/filebeat-bin"

# Do not complain about CFLAGS etc since go projects do not use them.
QA_FLAGS_IGNORED='.*'

S="${WORKDIR}/src/github.com/elastic/beats"

src_unpack() {
mkdir -p "${S%/*}" || die
default
mv beats-${PV} "${S}" || die
}

src_prepare() {
default

# avoid Elastic license
rm -r x-pack || die

# use ${PV} instead of git commit id
sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
}

src_compile() {
GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
}

src_install() {
keepdir /var/{lib,log}/${PN}

fperms 0750 /var/{lib,log}/${PN}

newconfd "${FILESDIR}/${PN}.confd" ${PN}
newinitd "${FILESDIR}/${PN}.initd.1" ${PN}

docinto examples
dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}

dobin filebeat/filebeat
}

pkg_postinst() {
if [[ -n "${REPLACING_VERSIONS}" ]]; then
elog "Please read the migration guide at:"
elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
elog ""
fi

elog "Example configurations:"
elog "${EROOT}/usr/share/doc/${PF}/examples"
}

0 comments on commit 442f98d

Please sign in to comment.