Skip to content

Commit

Permalink
dev-db/hyperdex: [QA] Add missing python metadata variables
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
SoapGentoo committed Apr 23, 2017
1 parent 0b2bbc3 commit 4460de5
Show file tree
Hide file tree
Showing 5 changed files with 74 additions and 36 deletions.
23 changes: 15 additions & 8 deletions dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

# Tests fail, again
RESTRICT="test"
PYTHON_COMPAT=( python2_7 )

PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools

DESCRIPTION="A searchable distributed Key-Value Store"
Expand All @@ -19,8 +18,13 @@ KEYWORDS="~amd64"

IUSE="test +python"
# need to add ruby and java useflags too
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"

# Tests fail, still
RESTRICT="test"

DEPEND="dev-cpp/glog
DEPEND="
dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
dev-libs/libpo6
Expand All @@ -30,17 +34,20 @@ DEPEND="dev-cpp/glog
dev-libs/replicant
dev-libs/libmacaroons
dev-libs/libtreadstone
dev-libs/json-c"
dev-libs/json-c
python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"

REQUIRED_USE="test? ( python )"
pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
use python && python-single-r1_pkg_setup
}

src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
Expand Down
23 changes: 15 additions & 8 deletions dev-db/hyperdex/hyperdex-1.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

# Tests fail, again
RESTRICT="test"
PYTHON_COMPAT=( python2_7 )

PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools

DESCRIPTION="A searchable distributed Key-Value Store"
Expand All @@ -19,8 +18,13 @@ KEYWORDS="~amd64"

IUSE="test +python"
# need to add ruby and java useflags too
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"

# Tests fail, still
RESTRICT="test"

DEPEND="dev-cpp/glog
DEPEND="
dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
dev-libs/libpo6
Expand All @@ -30,17 +34,20 @@ DEPEND="dev-cpp/glog
dev-libs/replicant
dev-libs/libmacaroons
dev-libs/libtreadstone
dev-libs/json-c"
dev-libs/json-c
python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"

REQUIRED_USE="test? ( python )"
pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
use python && python-single-r1_pkg_setup
}

src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
Expand Down
23 changes: 15 additions & 8 deletions dev-db/hyperdex/hyperdex-1.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

# Tests fail, still
RESTRICT="test"
PYTHON_COMPAT=( python2_7 )

PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools

DESCRIPTION="A searchable distributed Key-Value Store"
Expand All @@ -19,8 +18,13 @@ KEYWORDS="~amd64"

IUSE="test +python"
# need to add ruby and java useflags too
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"

# Tests fail, still
RESTRICT="test"

DEPEND="dev-cpp/glog
DEPEND="
dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
>=dev-libs/hyperleveldb-1.2
Expand All @@ -31,17 +35,20 @@ DEPEND="dev-cpp/glog
>=dev-libs/replicant-0.8
>=dev-libs/libmacaroons-0.3
>=dev-libs/libtreadstone-0.2
dev-libs/json-c"
dev-libs/json-c
python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"

REQUIRED_USE="test? ( python )"
pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
use python && python-single-r1_pkg_setup
}

src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
Expand Down
23 changes: 15 additions & 8 deletions dev-db/hyperdex/hyperdex-1.8.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

# Tests fail, still
RESTRICT="test"
PYTHON_COMPAT=( python2_7 )

PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools

DESCRIPTION="A searchable distributed Key-Value Store"
Expand All @@ -19,8 +18,13 @@ KEYWORDS="~amd64"

IUSE="test +python"
# need to add ruby and java useflags too
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"

# Tests fail, still
RESTRICT="test"

DEPEND="dev-cpp/glog
DEPEND="
dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
>=dev-libs/hyperleveldb-1.2
Expand All @@ -31,17 +35,20 @@ DEPEND="dev-cpp/glog
>=dev-libs/replicant-0.8
>=dev-libs/libmacaroons-0.3
>=dev-libs/libtreadstone-0.2
dev-libs/json-c"
dev-libs/json-c
python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"

REQUIRED_USE="test? ( python )"
pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
use python && python-single-r1_pkg_setup
}

src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
Expand Down
18 changes: 14 additions & 4 deletions dev-db/hyperdex/hyperdex-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

PYTHON_COMPAT=( python2_7)
PYTHON_COMPAT=( python2_7 )

inherit eutils python-r1 autotools git-r3

DESCRIPTION="A searchable distributed Key-Value Store"
Expand All @@ -18,24 +20,32 @@ SRC_URI="http://dev.gentooexperimental.org/~patrick/autotools-java.tar"

IUSE="+python"
# need to add ruby and java useflags too
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

DEPEND="dev-cpp/glog
DEPEND="
dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
dev-libs/libpo6
dev-libs/libe
dev-libs/busybee
dev-libs/popt
dev-libs/replicant
dev-libs/json-c"
dev-libs/json-c
python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
cd m4; tar xf "${DISTDIR}/autotools-java.tar"
cd ..
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
}

src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
Expand Down

0 comments on commit 4460de5

Please sign in to comment.