Skip to content

Commit

Permalink
dev-util/bazel: bump 0.24.1
Browse files Browse the repository at this point in the history
Signed-off-by: Jason Zaman <[email protected]>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
  • Loading branch information
perfinion committed Apr 26, 2019
1 parent 61ba13c commit 447b11d
Show file tree
Hide file tree
Showing 2 changed files with 121 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/bazel/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST bazel-0.20.0-dist.zip 87602213 BLAKE2B 0d10fc89a8bc2bf91a67317d42302b894abbec8c4e9f39dd4fbeae71fcba847d5ae35102e3ef4a26d7dfe2da9e47cec5660dd28e1804c3ad562583e9566b78cb SHA512 1628a99a2c95334b7b190c5cf1b80ad3ce61c827103844f68401ffe5cfa994d5b7edd9e314a2775b6ed5b8da70ad79bee0ef47b9acf409919a613069356623a3
DIST bazel-0.22.0-dist.zip 88633015 BLAKE2B 7cb7ef53c9acb4089b92d82679ad82739fd3c1fd3af7147e13b1474353fdf4cba1f58deed6d1880ec85fe5a07940b8df14af2701361d86e638b5c0e6924300c1 SHA512 b93cd21f0f164c118b90efba761a9492eb9894e24f13ff468defd12b86c7e67f16e51060ac2fc4c2f8dbf51b1c833d41b255fdd8107988e5babf093cfc5b3254
DIST bazel-0.24.1-dist.zip 174691842 BLAKE2B 56d42421ac6f5513f019f3b71ca0c5e7b499c199dd8d9f22ca4fdca832527a1974afffccd6bff6b1d29dc3156ee28ba7f91a9a37f2f8524da5c5f30645be97aa SHA512 a78c871eb517ec53a0d1d9592887288fa54e5e9f44b0b7dba44792a74a1ba0c98e38ff2f6094ab6e8b3add3ec4a0188de3b2489d94d419373e210d16db641774
120 changes: 120 additions & 0 deletions dev-util/bazel/bazel-0.24.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,120 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit bash-completion-r1 java-pkg-2 multiprocessing

DESCRIPTION="Fast and correct automated build system"
HOMEPAGE="https://bazel.build/"

SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="examples tools"
# strip corrupts the bazel binary
RESTRICT="strip"
RDEPEND="virtual/jdk:1.8"
DEPEND="${RDEPEND}
app-arch/unzip"

S="${WORKDIR}"
QA_FLAGS_IGNORED="usr/bin/bazel"

bazel-get-flags() {
local i fs=()
for i in ${CFLAGS}; do
fs+=( "--copt=${i}" "--host_copt=${i}" )
done
for i in ${CXXFLAGS}; do
fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
done
for i in ${CPPFLAGS}; do
fs+=( "--copt=${i}" "--host_copt=${i}" )
fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
done
for i in ${LDFLAGS}; do
fs+=( "--linkopt=${i}" "--host_linkopt=${i}" )
done
echo "${fs[*]}"
}

pkg_setup() {
echo ${PATH} | grep -q ccache && \
ewarn "${PN} usually fails to compile with ccache, you have been warned"
java-pkg-2_pkg_setup
}

src_unpack() {
# Only unpack the main distfile
unpack ${P}-dist.zip
}

src_prepare() {
default

# F: fopen_wr
# S: deny
# P: /proc/self/setgroups
# A: /proc/self/setgroups
# R: /proc/24939/setgroups
# C: /usr/lib/systemd/systemd
addpredict /proc

# Use standalone strategy to deactivate the bazel sandbox, since it
# conflicts with FEATURES=sandbox.
cat > "${T}/bazelrc" <<-EOF || die
build --verbose_failures
build --spawn_strategy=standalone --genrule_strategy=standalone
build --distdir="${S}/derived/distdir/"
build --jobs=$(makeopts_jobs) $(bazel-get-flags)
test --verbose_failures --verbose_test_summary
test --spawn_strategy=standalone --genrule_strategy=standalone
EOF
}

src_compile() {
export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs) --host_javabase=@local_jdk//:jdk"
VERBOSE=yes ./compile.sh || die

./scripts/generate_bash_completion.sh \
--bazel=output/bazel \
--output=bazel-complete.bash \
--prepend=scripts/bazel-complete-header.bash \
--prepend=scripts/bazel-complete-template.bash
}

src_test() {
output/bazel test \
--verbose_failures \
--spawn_strategy=standalone \
--genrule_strategy=standalone \
--verbose_test_summary \
examples/cpp:hello-success_test || die
output/bazel shutdown
}

src_install() {
dobin output/bazel
newbashcomp bazel-complete.bash ${PN}
bashcomp_alias ${PN} ibazel
insinto /usr/share/zsh/site-functions
doins scripts/zsh_completion/_bazel

if use examples; then
docinto examples
dodoc -r examples/*
docompress -x /usr/share/doc/${PF}/examples
fi
# could really build tools but I don't know which ones
# are actually used
if use tools; then
docinto tools
dodoc -r tools/*
docompress -x /usr/share/doc/${PF}/tools
fi
}

0 comments on commit 447b11d

Please sign in to comment.