Skip to content

Commit

Permalink
games-board/fruit: Stop using games.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
pacho2 committed Apr 29, 2018
1 parent 90fd10c commit 44e18c1
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 2 deletions.
4 changes: 2 additions & 2 deletions games-board/fruit/files/fruit-2.1-gentoo.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- option.cpp.old 2007-02-07 23:32:25.000000000 +0100
+++ option.cpp 2007-02-07 23:32:51.000000000 +0100
--- a/option.cpp.old 2007-02-07 23:32:25.000000000 +0100
+++ b/option.cpp 2007-02-07 23:32:51.000000000 +0100
@@ -29,7 +29,7 @@
{ "Ponder", true, "false", "check", "", NULL },

Expand Down
41 changes: 41 additions & 0 deletions games-board/fruit/fruit-2.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit versionator

MY_PV="$(replace_all_version_separators '')"
MY_P="${PN}_${MY_PV}_linux"

DESCRIPTION="UCI-only chess engine"
HOMEPAGE="http://arctrix.com/nas/fruit/"
SRC_URI="http://arctrix.com/nas/${PN}/${MY_P}.zip"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=""
DEPEND="app-arch/unzip"

S="${WORKDIR}/${MY_P}/src"

src_prepare() {
default
eapply "${FILESDIR}/${P}"-gentoo.patch
sed -i \
-e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
option.cpp || die
sed -i \
-e '/^CXX/d' \
-e '/^LDFLAGS/d' \
Makefile || die
}

src_install() {
dobin ${PN}
insinto "/usr/share/${PN}"
doins ../book_small.bin
dodoc ../readme.txt ../technical_10.txt
}

0 comments on commit 44e18c1

Please sign in to comment.