forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-user-share: Version bump
Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnome-user-share-3.18.0.tar.xz 376944 SHA256 feb3bed59193eafea31f563ed7eab5f066aa5f86d4a89f067b162653d168d3fc SHA512 bc053b879c602f2d6d04431f817f528c7f6ffb20e2078fcef1b4cc8acbe95a658fb6cfe03b55fe87c46bd87ea175cfdfda8314928e9c3525ccf2fa8ab0fdf055 WHIRLPOOL 72c43048afae3888306c8033d63458df7fd806bf21c99405b72b5694e03e73fc5a43473671da978aea5ae223f9bf4111a809c0a9f17f47f7d38a55dd25f08817 | ||
DIST gnome-user-share-3.18.1.tar.xz 388940 SHA256 3e64dacfadd9bdfbf080223d95e938b5b5ae4195a44cd75f51a4bb2547fa2cdd SHA512 2edf2ae13162020625dba1784ed06542f4ccedb981a3ad70455a26edf52bf64aa3fc02290a650dabe5f939b80dad67ab3d7e9551b9f3a6bd7998b0301df1918e WHIRLPOOL 12b758cd4a40aa7a72560f44e5b8d36c0335895617e0007225b5b807bb9291d14969dbe7b76795ea1246dcb2d49d90991fe87e15db3b32d50d38fec35240e5ad |
43 changes: 43 additions & 0 deletions
43
gnome-extra/gnome-user-share/gnome-user-share-3.18.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GCONF_DEBUG="no" | ||
GNOME2_LA_PUNT="yes" | ||
|
||
inherit gnome2 multilib | ||
|
||
DESCRIPTION="Personal file sharing for the GNOME desktop" | ||
HOMEPAGE="https://git.gnome.org/browse/gnome-user-share" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
# FIXME: could libnotify be made optional ? | ||
# FIXME: selinux automagic support | ||
RDEPEND=" | ||
>=dev-libs/glib-2.28:2 | ||
>=x11-libs/gtk+-3:3 | ||
>=gnome-base/nautilus-2.91.7 | ||
media-libs/libcanberra[gtk3] | ||
>=www-apache/mod_dnssd-0.6 | ||
>=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile,apache2_mpms_prefork] | ||
>=x11-libs/libnotify-0.7:= | ||
" | ||
DEPEND="${RDEPEND} | ||
!<gnome-base/gnome-control-center-3.9 | ||
app-text/yelp-tools | ||
app-text/docbook-xml-dtd:4.1.2 | ||
>=dev-util/intltool-0.35 | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
" | ||
|
||
src_configure() { | ||
gnome2_src_configure \ | ||
--with-httpd=apache2 \ | ||
--with-modules-path=/usr/$(get_libdir)/apache2/modules/ | ||
} |