Skip to content

Commit

Permalink
dev-libs/libofx: bump package
Browse files Browse the repository at this point in the history
* non-maintainer security bump
* drop PPC/PPC64 keywords due to new dep on dev-util/gengetopt
* move from autotools-utils to autotools eclass
* bump EAPI
* Update HOMEPAGE and SRC_URI
* move RDEPEND deps to DEPEND where they belong

Bug: https://bugs.gentoo.org/631304
Bug: https://bugs.gentoo.org/636062
Bug: https://bugs.gentoo.org/662910
Closes: https://bugs.gentoo.org/675152

Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
FuzzyGophers committed Aug 18, 2019
1 parent 8511e93 commit 451fc2c
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libofx/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libofx-0.9.10.tar.gz 1433837 BLAKE2B 131be0243b8450d32417dd75f0421744412a3186c0f7a3451883b6572c0dd27427579baf280ac2ae6409d0738bd578f69eaa9debfe50024411c6b0ccad11f5c9 SHA512 061110702034dbbb9be3adaebe6236a4b0842169d8ee7671bad6c93960b380cbb33953bdf080c8b14f45930b0c817fcfe1bf71f15d9872dd2535a1415f5be895
DIST libofx-0.9.14.tar.gz 210155 BLAKE2B 1b5ee8503dd9d4837415e53ae79889c32c50146b2b508aab052e8074a277f8181c6866470220758ed7997b0b6e3e524ac6f9e1cac9a673f60c30ce3093e5a3ee SHA512 785c5130fc6f6cfc019d4aee2bf6de6311835e5dc7f2bd56a83f1ecf5e62ecb320a95bf4a5ff8f9e14dcaf5ff1eabc833cd7974927e571a8469c9a02fb8362d2
56 changes: 56 additions & 0 deletions dev-libs/libofx/libofx-0.9.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools flag-o-matic

DESCRIPTION="A library to support the Open Financial eXchange XML format"
HOMEPAGE="https://github.com/libofx/libofx"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="static-libs test"

RDEPEND="
>=net-misc/curl-7.9.7
virtual/libiconv
"
DEPEND="${RDEPEND}
>app-text/opensp-1.5
>=dev-cpp/libxmlpp-2.40.1:2.6
dev-util/gengetopt
sys-apps/help2man
virtual/pkgconfig
test? ( app-crypt/gnupg )"

# workaround needed for ofxconnect to compile
MAKEOPTS="-j1"

src_prepare() {
default
eautoreconf

# we will tell you where we wants the docs!
sed -i -e 's:docdir.*::' Makefile.am || die
sed -i -e 's:docdir.*::' dtd/Makefile.am || die

# configure arguments alone don't disable everything
sed -e "/^SUBDIRS/s/doc//" -i Makefile.am || die

append-cxxflags -std=c++14

# build will fail without this. shenanigans...
touch INSTALL || die "failed to touch INSTALL"
}

src_configure() {
econf --docdir=/usr/share/doc/${PF}
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 451fc2c

Please sign in to comment.