Skip to content

Commit

Permalink
gui-libs/neatvnc: clean vnc library for wayland
Browse files Browse the repository at this point in the history
can be used by any vnc server for wlroots
based compositors

Package-Manager: Portage-2.3.101, Repoman-2.3.22
Signed-off-by: Aisha Tammy <[email protected]>
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
epsilon-0 authored and FuzzyGophers committed Jan 25, 2021
1 parent cc377d2 commit 452849c
Show file tree
Hide file tree
Showing 4 changed files with 108 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-libs/neatvnc/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST neatvnc-0.4.0.tar.gz 555438 BLAKE2B d6676521c3bceb43055589406419c12aca8139b561dc2f9de1ac3abae3e3c84e7ce133fb18a6206941ee9a00306a3c5c4dbebf2c36b15e57a11bd950a20f69a6 SHA512 cfbba3e81e1319b3c0f87644c7fb92e2a72d993c107722d6cb2e23674e1c4bfe9c281442a508a14d3e16964529d0646d1b9726d8f081157fb902454637346a7d
17 changes: 17 additions & 0 deletions gui-libs/neatvnc/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Aisha Tammy</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<use>
<flag name="examples">Build and install examples</flag>
<flag name="jpeg">Enable fast encodings</flag>
<flag name="tracing">Trace kernel and memory calls</flag>
</use>
</pkgmetadata>
45 changes: 45 additions & 0 deletions gui-libs/neatvnc/neatvnc-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="liberally licensed VNC server library with a clean interface"
HOMEPAGE="https://github.com/any1/neatvnc/"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
else
SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="ISC"
SLOT="0"
IUSE="examples ssl jpeg tracing"

DEPEND="
x11-libs/pixman
x11-libs/libdrm
dev-libs/aml
sys-libs/zlib
ssl? ( net-libs/gnutls:= )
jpeg? ( media-libs/libjpeg-turbo:= )
tracing? ( dev-util/systemtap )
"
RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
"

src_configure() {
local emesonargs=(
$(meson_use examples)
$(meson_feature jpeg)
$(meson_feature ssl tls)
$(meson_use tracing systemtap)
)
meson_src_configure
}
45 changes: 45 additions & 0 deletions gui-libs/neatvnc/neatvnc-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="liberally licensed VNC server library with a clean interface"
HOMEPAGE="https://github.com/any1/neatvnc/"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
else
SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="ISC"
SLOT="0"
IUSE="examples ssl jpeg tracing"

DEPEND="
x11-libs/pixman
x11-libs/libdrm
dev-libs/aml
sys-libs/zlib
ssl? ( net-libs/gnutls:= )
jpeg? ( media-libs/libjpeg-turbo:= )
tracing? ( dev-util/systemtap )
"
RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
"

src_configure() {
local emesonargs=(
$(meson_use examples)
$(meson_feature jpeg)
$(meson_feature ssl tls)
$(meson_use tracing systemtap)
)
meson_src_configure
}

0 comments on commit 452849c

Please sign in to comment.