Skip to content

Commit

Permalink
games-fps/rott: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: Portage-2.3.2, Repoman-2.3.1
  • Loading branch information
austin987 committed Feb 14, 2017
1 parent dcd4606 commit 452c7c7
Showing 1 changed file with 56 additions and 0 deletions.
56 changes: 56 additions & 0 deletions games-fps/rott/rott-1.1.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils

DESCRIPTION="Rise of the Triad for Linux!"
HOMEPAGE="http://www.icculus.org/rott/"
SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
demo? ( http://filesingularity.timedoctor.org/swdata.zip )"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="demo"

RDEPEND="media-libs/libsdl[sound,joystick,video]
media-libs/sdl-mixer"
DEPEND="${RDEPEND}
app-arch/unzip"

S=${WORKDIR}/${P}/rott

src_prepare() {
default

sed -i \
-e '/^CC =/d' \
Makefile || die "sed failed"
emake clean
}

src_compile() {
emake -j1 \
EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"/usr/share/${PN}/\\\"" \
SHAREWARE=$(usex demo "1" "0")
}

src_install() {
dobin rott
dodoc ../doc/*.txt ../README
doman ../doc/rott.6
if use demo ; then
cd "${WORKDIR}" || die
insinto /usr/share/${PN}
doins *.dmo huntbgin.* remote1.rts
fi
}

pkg_postinst() {
if ! use demo ; then
elog "To play the full version, just copy the"
elog "data files to /usr/share/${PN}/"
fi
}

0 comments on commit 452c7c7

Please sign in to comment.